Lakka 2.1.1 (?) via NOOBS not booting on Pi 3B+


#1

I just tried installing Lakka alongside other OSses via NOOBS but, while the others (Raspbian, LibreELEC) boot just fine, Lakka hangs on a black screen with a lightning bolt showingin the top right corner and the Pi flashing the power light. Any idea what might be causing this?


#2

not enough juice for the pi. use a 2w unit.


#3

I’m using the official Pi 3 wall charger, shouldn’t that output enough power? Also, all the other NOOBS-installed OSses do boot, as did OSMC previously, are there special power requirements for booting into Lakka?


#4

it was my previous experience; i was using an underpowered psu, and got the blinking power led.

so no, lakka does not require a beefier power supply. :slight_smile:


#5

also, i’ve just read here http://www.lakka.tv/get/windows/generic/ that we don't support virtualization and dualboot.

so there’s your answer.


#6

Aren’t NOOBS-builds specific to NOOBS? I did not use a downloaded installer or image, NOOBS itself pulled it from it’s repository (?) of compatible OSses, it wasn’t available pre-2.2.1 on Pi 3B+s and only appeared since the latest release.


#7

Can one of the devs perhaps confirm if the current build available via NOOBS should in fact work on the 3B+? Or someone else who has this setup (not) working?

It only became availabe since the release of 2.1.1, so to me that seems that it was deemed compatible by whoever maintains the repository NOOBS pulls from.


#8

So I was messing with it a bit and trying to get the Lakka build that’s in NOOBS to work and just couldn’t. I don’t really know much about linux in general but I’ve been programming long enough to figure out how to make things work when they probably shouldn’t.

I ended up just making a new OS entry and manually making the package and that got it to work. Here’s a quick overview of what I did and then I’ll include the link that inspired what I did. I’m working off a windows machine so there were some extra growing pains.

  • Download NOOBS and extract it locally (not the Lite version)
  • Download the image from Lakka’s site
  • Flash it onto an SD card
  • Copy contents from the Lakka partition to a local drive
  • Write down the size of that partition (need it later; ref 1)
  • Tar the contents of the folder to a file named System.tar. (I used 7zip for this)
  • Write down the size of the .tar file (ref 2)
  • Compress the System.tar file to a System.tar.xz file (I used XZ Utils from https://tukaani.org/xz/ and don’t forget the parameters of -9 -e -v)
  • In the extracted NOOBS folder make a copy of the LibreELEC_RPi2 (or comparable version) folder
  • Delete the System.tar.xz folder from the copy and replace it with the System.tar.xz you just made
  • Edit os.json and update the name/description to be something more meaningful to you. (also note the username/password or change it so you remember. May need this if you use SAMBA to move roms over)
  • Edit partitions.json. Update the “partition_size_nominal” to be the size of the partition you wrote down (ref. 1) and change “uncompressed_tarball_size” to be the size of the .tar file you wrote down (ref. 2).

Go ahead and load up the SD card as if you were doing a fresh NOOBS install, but with your new OS in the os folder. You can use Lite at this point, but you’ll still need to have this custom OS in that folder. Now when you load up the installer you should see whatever name/description you put in the os.json file.

After installing it this way, I was able to boot into it and load up some roms. Below is the link I used as an example.

It sucks that it’s super manual, but hey, that’s what RPi is all about right? Breaking stuff until it’s not broken anymore! This is also my first real attempt at interacting with the NOOBS launcher and making custom stuff, so if anyone sees something that I did is an error feel free to point it out so other people don’t make it. I’m pretty sure I’m too tired to undo it in my instance lol.

p.s. It probably wouldn’t be a terrible idea to actually load up your roms just after you flash the SD card in the beginning so that they actually unpack with the OS if you have to reload the device again. Unless, of course, you’re keeping them external and/or really enjoy scanning thousands of files :slight_smile:

Hope that helps!


#9

i found a different solution that might help and that is using pinn a noobs fork


#10

other multiboot option is berryboot. Lakka (along with LibreELEC, Volumio2) integration is provided here


#11

I’m using a Pi 3 B+ with the CanaKit power supply and I also experienced this problem. I solved it by downloading the Lakka 2.2.2 image and replacing the entire contents of my SD card with it. I would like to continue using NOOBS though, so I am disappointed in this solution.


#12

Yeah but PINN installs an older version of Lakka that isn’t working with the Pi 3B+. No networking is available.


#13

Have you found any solution to duel booting LibreELECT/OSMC with Lakka?