Lakka builds on RPi4: some device tree overlays not working

Hi all

Device tree overlays can be used to easily add some extra functionalities to RPi devices via the GPIO pins, without using custom scripts. A power on/shutdown button (gpio-shutdown) and automatic temperature fan control (gpio-fan) can be enabled in Raspbian by just adding some lines to /boot/config.txt.

I tested these device tree overlays with Lakka and found that, using the latest stable release (2.3.2), gpio-shutdown works fine, but gpio-fan does not work. However, when testing the 2020-02-13 nightly build (latest one for RPi4), the situation is reversed: gpio-shutdown does not work anymore, but gpio-fan now works fine…

Can this be fixed with some workaround, so that both DT overlays work?

Best regards


Hello I am looking for some way to control a fan on Rpi 4b with Lakka 2.3.2 On Rasbian I used this guide and worked fine.

In Lakka it seems it’s not possible. You wrote I can use DT overlays. My fan is controlled by GPIO 17 Is this instruction correct (start at 65C)? dtoverlay=gpio-fan,gpio_pin=17,temp=65000

Then the system should start fan at 65C and turns it off at? Thanks


Like I wrote before, gpio-fan currently only works with the Lakka nightly builds. It doesn’t work with the current stable version 2.3.2. Why, I have no idea… I was hoping someone from the dev team could have a look at this issue, as dynamic fan control would be really useful.

All DT overlays work in Raspbian. For gpio-fan without any parameters, the fan is switched on at 55 °C and off at 45 °C, so I guess there’s a 10 °C difference.



1 Like

Ok Thanks so the python method described in the above link is unuseful… Except if you want to start/stop your fan at desired temperatures.

While the DTOverlay is broken in Lakka stable, do you know if there is some way to control a GPIO with it? I have a multiboot sd card with rasbian and lakka and in rasbian I control the rsap fan with gpio 17, I’ll like to do the same with lakka. I’m not skilled in coding, sorry

Thanks Pietro


I’m not skilled in coding either… :wink:

Currently, my fan is always on. I use a circuit similar to that in the above link, with fan control wired to GPIO 14, GND and +3.3V. It is switched on by the parameter enable_uart=1 in config.txt, and switched off on shutdown. I don’t run Lakka continuously, so that is enough for me. But of course a dynamic fan control would be way better. Since dtoverlay=gpio-fan works fine in the nightly builds, I suppose eventually we will get it in the stable build.

What puzzles me is why dtoverlay=gpio-shutdown does not work anymore with the nightly builds… Maybe it was forgotten/disabled by mistake.

Let’s hope someone with better technical knowledge of Lakka can have a look at this :slight_smile: