Lakka does not recognize me neither keyboard nor mouse nor the pad


#1

Hi,

I have managed to put Lakka 2.1(Lakka-S905.arm-2.1.img.gz) on Android box S905: Mecool m8s Pro+ but I can’t navigate in the menus. If I remove the SD card and the box starts normally with Android O.S and when I connect the mouse, the keyboard or the gamepad (Gamesir g3s) everything is recognized and I can use them but when I start the box with the SD card and Lakka 2.1 starts when I connect these inputs are not recognized and I can’t move inside the menus.

Can someone guide me or advise me something?

Thanks.


#2

Let’s start with the basics:

  1. How are you trying to connect your keyboard/mouse combo and or the Gamesir G3s controller?
  2. Since you can remove the micro SD card, boot up Android and connect everything, and everything works, the connections to the various devices are able to work, but you haven’t stated HOW you’re connecting them to your device.

Let’s start there, and then move forward.


#3

Hello, you are right:

Mouse is a USB Targus: Picture

Keyboard is a USB NGS red skin sport keyboard: Picture

Gamepas is a USB/Wireless Gamesir 3gs: Picture

If I start the box normally with Android O.S and connect the mouse or the keyboard or the gamepad (wired USB and wireless adding the USB receptor dongle) are recognized.

If I start the box with Lakka and connect the mouse or the keyboard or the wired USB gamepad are not recognized. Any message is showed in Lakka of device connected.

If I start the box with Lakka and the mouse or the keyboard or the wired USB gamepad are connected previously before turn on the box are not recognized.

The box have USB ports, I have tested both.


#4

I’m glad you didn’t react like I was being a smartass (because I genuinely wasn’t).

Which now leads to more questions: when you boot up Lakka with the peripherals disconnected from the USB ports, and then plug them in, does Lakka/Retroarch acknowledge that you plugged in the device(s)? Lakka supports the Gamesir G3s controller for the 2.4 GHz wireless dongle. I should know, because I tested it on the Odroid XU4’s USB 2.0 port and used the X+Home button to configure it as an XBox 360 controller. Lakka can also pick it up as a Gamesir G3s controller as well, so I’m pretty sure it has the udev drivers for it.


#5

Lakka/Retroarch not show any message when I connect the keyboard, mouse or gamepad. I tested the Gamepad Gamesir 3gs wired.

As a curiosity I will try again the Gamesir G3s controller with the 2.4 GHz wireless dongle but it does not matter anymore, I’m going to sell this weak Android box and buy a stronger and better mini PC for use Lakka.

Anyway thanks for your help.


#6

Tried Different Mouse and/or Keyboard?


#7

I have tried two different mouses and one keyboard and all of them work if I start the box with Android. These same devices not working if I start the box with Lakka but I have seen some important what I believe is the problem: with Android if I connect the mouses (optical) then the led under the mouse turn on and shines but I start the box with Lakka when I connect the mouses the led don’t turn on and is off so I think with Lakka the USB ports don’t receive power, I don’t know why, over Android these ports receive power.


#8

Do you reproduce the issue with our nightly builds ?


#9

I just tried last nightly build version for s905: Lakka-S905.arm-2.1-devel-20180530064205-r28190-gcc135d4.img.gz but it didn’t boot in my box. I followed the same steps like I did with stable version 2.1.


#10

Hello

Was this issue ever solved? I have a a95x r1 runing in a s905w cpu 2g ram 16 g storage . I am running the tanix t3 min dual boot firmware all was doing great until i told retroarch to do the lakka.2.2.1 update. Now im stuck in lakka with no controller , keyboard or mouse , I can not get to the android boot loader and usb burn card wont stay connected

Any help would be greatly appreciated Thank You


#11

Ufortunely ssh was turned off durring the update so i can not connect to the box via putty