Lakka nightly cifs problem

Running the 15-08 nightly on a pi4 and having problems mounting my NAS over CIFS.

I tried following but that does not work, it seems that the instructions need some updates regarding the need for the vers= setting at a minimum (and possibly also the noserverino setting which seems like it is needed on arm devices with retroarch.

In any case, the mounts fail, this is what systemctl says failed after adding the options:

● storage-roms-nas.mount - cifs mount script
   Loaded: loaded (/storage/.config/system.d/storage-roms-nas.mount; enabled; vendor preset: disabled)
   Active: failed (Result: exit-code) since Wed 2019-07-24 13:01:36 UTC; 3 weeks 2 days ago
    Where: /storage/roms/nas
     What: //
  Process: 482 ExecMount=/usr/bin/mount // /storage/roms/nas -t cifs -o guest,ro,vers=3.0,noserverino (code=exited, status=255)

Jul 24 13:01:36 Lakka systemd[1]: Mounting cifs mount script...
Jul 24 13:01:36 Lakka systemd[1]: storage-roms-nas.mount: Mount process exited, code=exited status=255
Jul 24 13:01:36 Lakka systemd[1]: Failed to mount cifs mount script.
Jul 24 13:01:36 Lakka systemd[1]: storage-roms-nas.mount: Unit entered failed state.

Obviously not very useful. And no errors in syslog either.

Trying to mount it manually also does not work

Lakka:~ # /usr/bin/mount -t cifs //nas/Media_Kids/Games /storage/roms/nas -o guest,ro,vers=3.0,noserverino
mount: mounting //nas/Media_Kids/Games on /storage/roms/nas failed: Invalid argument

The system can resolve ‘nas’ fine, and replacing it with the IP gives the same error. Looking around however, I noticed mount.cifs is missing, and I am starting to suspect this may be the problem.

smbclient works fine.

Lakka:~ # smbclient //nas/Media_Kids
Enter WORKGROUP\root's password:
smb: \> ls
  .                                   D        0  Sat Sep 22 16:45:16 2018
  ..                                  D        0  Mon Sep 21 13:49:29 2015
  Games                               D        0  Fri Mar 22 11:47:54 2019
  Videos                              D        0  Sat May 21 17:56:36 2016
  Music                               D        0  Sun Sep 24 15:58:18 2017
  Books                               D        0  Sat Sep 22 17:01:39 2018

                6822611264 blocks of size 1024. 2309165340 blocks available
smb: \> q

Hi @Robert. This could be outdated, but there was a discussion related to a fix for NAS devices that was discussed here:

The summary is that using vers=1.0 should fix it. I must say though that I have no way of testing myself since I don’t have NAS.

Thanks for the reply, unfortunately I had already tried the vers= option as mentioned in the original post. I have tried vers=1.0, 2.0, 2.1 and 3.0, all of which gave the same error.

Hi @Robert / anyone else out there - trying the latest stable Lakka on RPi4 and getting the same. The main instructions here have not been updated in a while and just wondering if something has changed. Confirm that vers 1, 2, 3 don’t change behaviour either -> still an issue.

Trying to just go from the command line (using a credentials file due to strong password):

Lakka: ~ # /usr/bin/mount -t cifs //NAS/path/roms /storage/roms/nas -o credentials=cifs.credo,vers=1.0

mount: mounting //NAS/path/roms on /storage/roms/nas failed: No such device

Edit: also I can’t seem to use smbclient on new RPi4 stable to confirm connectivity but I am sure of IP/alias of NAS on my network

Lakka: ~ # smbclient

-sh: smbclient: not found

I just tried it again just now with Lakka 2.3.1 on my RPi4, and the errors are the same. In addition, as noted by @TyroneSlothrop the smbclient command has been removed, so cannot be used any longer to ensure you can actually access the NAS.

Also @TyroneSlothrop your error is different from mine, so it appears you may not be running into the exact same problem. Your getting a “No such device” error, while I’m getting “Invalid argument”. The only way I found I can get a “No such device” error is if I mistype the “-t cifs” parameter.