Lakka - Nightly Performance and New Stable Version

While waiting for the new stable version for the RPi4 (2Gb), I decided to try out one of the new nightlies (32-bit).

Very pleased with the new Ozone theme and impressed with the new Swanstation core (provided I set it to software rendering mode - HW rendering makes most games stutter). Swanstation eliminates several graphical glitches I found on on PCSX-Rearmed (‘internal section’s’ on-screen score bonus display and ‘R-Type Delta’ text panels and stuttering audio after ship selection) and crashes (‘R-Type Delta’ after continue screen).

However, I noticed that the framerates on all systems… even 8-bit systems are somewhat jittery and is especially noticeable on scrolling games. This is a pity, as I would like to use the nightlies as my primary OS until the new stable version is released. However, the jittery scrolling really bugs me, so I went back to the stable version.

Are there any tips on resolving this and is there any timeline for the release of the new stable version? Thanks.

Try the nightly from the 4th April instead, this is before the 5.10 kernel update (this is the last 5.4) and you’ll find the UI and the scrolling should be smooth.

https://nightly.builds.lakka.tv/2021-04-04/

1 Like

Ah, thanks for the advice. I will try this version later this evening. BTW, why is the performance on the new kernel update causing these performance issues? I’m assuming it’s a matter of optimization?

The performance and scrolling are perfect :slight_smile: Much appreciated. However, I can’t get the audio to work. I’m using an HDMI to VGA converter with a 3.5mm audio jack. Are there any audio settings on this version I should adjust?

Go to Audio/Output and then ‘Device’ and see if you can cycle through the lists if it’s shown? If ‘Device’ is blank, then just enter ‘null’ from keyboard and restart Retroarch, then go back and the available outputs should be seen.

Not sure why 5.10 isn’t working correctly on the recent RPi4 builds, but it’s definitely a regression at the moment unfortunately.

1 Like

Has the regression been reported and posted on Lakka Github page?

That worked! Unfortunately, it does seem as if the scrolling is as bad as it was on the later nightlies… Aaaarrggh! Oh well. I think I’d better just wait for the next stable release. Thanks for your help.

I have noticed something interesting. I set my audio device to ‘default=headphones’ and this seems to be what is causing the jittery scrolling. I disabled it (ie. set back to ‘null’) and the scrolling is fine. Do you know which are the device names I should use for the HDMI to VGA headphone jack or what I should use for my small USB soundcard? My normal device name for my soundcard which normally works on the stable build doesn’t work in this version.

You can’t cycle through the list of audio devices ? There is an example in this video to switch audio device to usb soundcard.

Please try to provide audio logs.

Thank you.

Unfortunately not. I can only cycle between them after I manually type in ‘null’ and restart Retroarch. After getting a sound option that works, the performance begins to stutter again. (Note: I can cycle in the stable version as well as the latest nightlies. Unfortunately, I cannot cycle in the 2021-04-04 nightly.) I will try get you an audio log from the 2021-04-04 nightly.

Also which resolution are you using ? You get stutter will all cores ?

I don’t have an RPI 4, but I’ve had an issue where a misconfigured audio setup had actually caused the stuttering. On my Banana Pi, the games would sometimes stutter when the audio was set to a device that didn’t actually exist, due to driver issues.

To debug audio, you could try the following: Lakka documentation - Troubleshooting Lakka See “Audio device logs” and post the output here. Also, compare the output with the stable version that had no issues.

The correct audio device for a HDMI to VGA headphone adapter would be just the standard HDMI audio output. You shouldn’t set any “headphones” or “analog” audio output. Again, I do not have an RPI so I cannot tell you the correct device names, but the first step would be to see if your system can find the HDMI sound card.

If I remember correctly, the RPI has some settings that you can set at boot time to tell it where to output audio, either in a config.txt file on the boot partition or on the kernel command line. Once that is set up properly, the kernel audio driver needs to be loaded, and finally the alsa configuration needs to be set to the correct sound card to send the output there.

1 Like

I’m using a VGA CRT at 1024 x 768. I haven’t tested many cores, but I have noticed the stutter on the Nestopia and Genesis Plus GX cores.