Lakka not booting or graphical corruption on live USB, PC with AMD APU


#1

I’m testing Lakka (current release) on a PC with an AMD APU, so no graphics card.

Booting from USB gets as far as the SYSLINUX and ‘boot:’ text, after that I just get a garbled screen.

There’s no indication of Lakka stuck in a restarting loop, nor of the PC rebooting. It may be that Lakka has started, but I can’t tell if it’s showing the berry logo and got stuck, or even at the menu.

I run Linux Mint in ‘normal’ use on this PC, so it’s puzzling me why Linux-based Lakka doesn’t boot correctly. I’ve taken lshw and lspci logs from the PC running Mint.

I just tested the live USB on a motherboard with an older generation AMD APU, and that worked fine.

Any pointers? Thanks.


#2

Is this the athlon 200 ge? Get’s down to kernel support. The 200ge needs kernel 4.18+ and mesa 18.1 for full support.

From this commit lakka is using 4.17 for x64 at the moment. https://github.com/libretro/Lakka-LibreELEC/commit/76627075e19e1d2933ecc91907c3fdfbe575103d

If you already have mint on there you can add retroarch from the repo alongside or use the snap package.

Terminal usage

For snap

sudo snap install retroarch (installs all cores)

For retroarch

sudo add-apt-repository ppa:libretro/stable

sudo apt-get update

sudo apt install retroarch retroarch-assets libretro-*

Where libretro-* installs all cores, if you only want specific cores list is at https://launchpad.net/~libretro/+archive/ubuntu/stable?field.series_filter=bionic


#3

Hi, thanks for the detailed reply. The APU is actually an A6-9500E, from the Bristol Ridge line.

I was actually intending to build a second PC using the same APU and dedicate it to Lakka (or upgrade my main PC to the Athlon 200GE or Ryzen 3 2200G, and shift the A6 across to the Lakka system - same result of course), if the A6 was capable of running PS1, N64, and possibly Saturn and Dreamcast. Hence wanting to test from the live USB.