Lakka Pi 4 + max run speed not working

Lakka on pi4 doesn’t seem to be respecting the Maximum Run Speed option under Frame Throttle. I want to run CPS2/3 at native refresh, but it sticks to 60hz unless I turn on Vsync + freesync, which makes the game lag a bit. Playing X-Men vs Street Fighter this way, I need to runahead 3 frames to get input lag like the arcade board on the pi4. If I turn Vsync off, even at 60hz, I get frame drops every few seconds.

The pi 3 does follow Maximum Run Speed very well. This + Vsync off + dispmanx video driver and the game runs at 59.630hz which is very close to native. How do I get lakka on pi4 to do that?

I’m running the pi4 on my arcade monitor with a 3840x240 timing line in config.txt. I tried the latest Nightly and stable - same issue with both.

This is going to come down to your modeline, I think. That is, if you have a 60.0 Hz modeline and you run at 59.630 Hz, you’re going to get frame dupes/drops every few seconds due to the mismatch.

These are the lines I’ve been using:

Pi4: hdmi_timings=3840 1 109 343 343 240 1 3 5 14 0 0 0 60 0 72925291 1 # 3840x240

Pi3: hdmi_timings=1920 1 152 246 280 240 1 3 7 12 0 0 0 60 0 40860000 1 #1920x240

I’ll be honest, I have no idea what those numbers mean or how to use them, but Max run speed works properly on the pi3 but not the pi4 with those. :frowning:

Hmm it looks like a bug. Max run speed works better on Mame and FB Alpha 2012. It stutters but it’s not as badly as in FB Neo. It has the “Set display reported refresh rate” to the game’s native refresh instead of 60hz. When I run a game with vsync + freesync on FBA, it doesn’t run too fast like it does on FB Neo.