Lakka rpi Zero can't add cores

Can’t seem to add cores to storage/cores. The ones I tried have the *.info file already in the build.

For example, I tried to add MAME2003+ (extracted the *.so from, it shows up in select cores, but once selected Retroarch just restarts.

Why did it not work?

Which version of Lakka are you using? I suspect that the latest Lakka is using a different kernel/libc than the one used to compile the nightly RetroArch Cores.

2.3.1 for the rpi Zero / GPi

If so, is there an archive for older cores? Any other MAME2003+ core I could try?

I think the only way is to compile the cores for Lakka manually.

1 Like

Out of curiosity: What is wrong with the mame2003+ preinstalled in LAKKA?
Usually you don’t need to add cores manually.

[EDIT] i noticed LAKKA has only the mame2000 core installed.


The CPU in the Raspberry Pi 1 and Zero implements the ARMv6 ISA (with VFP2) and is thus incompatible with the Debian armhf port baseline of ARMv7+VFP3 and ARM hardware-floating-point ports for other distributions, which all have the same baseline. It is compatible with Debian armel (armv4t, soft(emulated) FP), but floating-point tasks will be slow when running the Debian armel port. (This doesn’t stand for newer families)

This means you have to compile it yourself as @duduke said

1 Like

Thank you, now it makes sense.