Lakka tv hdmi audio fix


#1

ISSUE: LAKKA IS INSTALLED ON PC CONNECTED TO TV, THRU HDMI CABLE, BUT SOUND WILL ONLY PLAY THRU PC’S INTERNAL SPEAKER

STEPS: TO GET AUDIO TO PLAY THROUGH TV INSTEAD:

  • Connect thru SSH with Putty
  • For noobies: Go to following site to download Putty: https://www.chiark.greenend.org.uk/~sgtatham/putty/latest.html
  • After you install and open Putty you will see a field named: Host Name (or IP address)
  • Type the IP of the device you have LAKKA installed on
  • You can find the IP by going to System Settings in LAKKA
  • After typing in IP address click the “Open” tab at the bottom of Putty
  • At this point you should see a terminal window open which will ask you for a username and password
  • For LAKKA, username = root and password = root

At this point type the following at the prompt:

systemctl stop retroarch

mount -o remount, rw /flash

nano /flash/config.txt

After the last entry a black/blank screen will appear with no entries: Type the following entry:

audio_device = “hdmi:CARD=HDMI,DEV=2”

Then use the following key combo to save the file:

CTRL + X

Type “Y” for yes to save file.

This will bring you back to the LAKA prompt.

Type the following:

mount -o remount,ro /flash

reboot

If all went well you should now only hear the audio thru your TV rather than the PC.

TROUBLESHOOTING THE INSTRUCTIONS ABOVE:

If is still does not work then try the following:

Type the following at the Laka prompt:

aplay -L

You will then see a list of all the sound card settings/devices on your PC that LAKKA recognized. You may have to change the following entry to reflect your PC’s particular settings:

audio_device = “hdmi:CARD=HDMI,DEV=2” (This setting may not work for your PC) If not then try one of the following:

audio_device = “hdmi:CARD=HDMI,DEV=0”

audio_device = “hdmi:CARD=HDMI,DEV=1”

audio_device = “hdmi:CARD=HDMI,DEV=3”

audio_device = “hdmi:CARD=HDMI,DEV=4”

This particular part of the entry could appear different on your PC: “hdmi:CARD=HDMI,DEV=2” For example, you may want to play the sound thru your TV, PC monitor, or surrond sound speakers, but your connections is a Display port or DVI

If it is different then use the entry you see that most closely matches the setting you need.

Before you make any changes, follow these steps again:

At LAKA prompt type:

systemctl stop retroarch (This stops the Retroarch service so you can make changes)

mount -o remount, rw /flash (This allows you to write to the file. It’s normally read-only)

nano /flash/config.txt (This opens the text file you need to change)

MAKE ANY CHANGES THEN TYPE:

mount -o remount,ro /flash (This makes the file read-only again)

reboot (Reboots LAKA)

I hope this tutorial helps you stop pulling your hair out :slight_smile:

-jmp4me


Generic PC x64 Build No HDMI Audio
No sound hdmi to tv
#2

Thank you for this tutorial but you can switch audio device from the gui.


#3

Yes, I did notice that. However, in my case, switching thru the GUI did not work. Manually adding the entry, to the config file, seemed to be the only method that worked.
Thanks


#4

Which Lakka version are you using ? On which platform ?

Is it possible to provide a Lakka system log ?


#5

I’m using your latest stable 64 bit build. I believe it’s v 2.1 on an HP Intel i5 desktop PC. LAKKA is installed as the only OS on the PC.


#6

I too am having this problem… Lakka works great on my machine except for audio over HDMI. Audio plays fine over the internal speaker (which I dont want) but when I choose any of the HDMI outputs there is no sound to the TV.


#7

i want to attempt to use lakka as the only OS on a pc, to tv setup via hdmi, however when i used the boot lakk usb without installing and restarted my pc there was no sound on TV, if i wipe windows, and use lakka os, how would i be able to fix the sound issue without having another os? dont want dual boot, i need it to turn on and be navigatable with a controller instead of having to go into bios and choose usb then restart. (older pc plus needs to be easy to use with a controller from boot)


#8

You should be able to change the audio device from within Lakka, but if that doesn’t get you fixed up, you’ll probably want to have another PC handy to remote into it and change some things on the fly. Once it’s setup, though, you won’t have to mess with it again in the future.


#9

How can I switch audio device with Orange Pi PC version? It seems there is no audio output through jack no matter how I tweak the settings.


#10

Hello, I am having similar issues with HDMI audio. I am using an AMD NUC PC with DP and HDMI ports. I see HDMI connected via SSH and have tried all diagnostic steps via the troubleshooting pages Lakka documentation and within the forum, but still unable to resolve it. I have used multiple HDMI cables and also have two exact same model mini PCs doing the same thing. I want to say the driver is not detected since I do not see any devices listed via the GUI to select an audio device. Here are my SSH log outputs for diagnostics…Thanks for any help I receive!

Here is a link to the diagnostic logs shared from my Google Drive

https://drive.google.com/drive/folders/1m4we3EzhKZVo2Rg2M90qj3nH6PUb_lgU?usp=sharing


#11

Does this apply to RetroArch? I’m using HDMI through TV for my PC. I’m looking for any other ideas of something I could try for getting the sound to work… the drivers are good and have the recent update, I’ve tested the speakers and it works in other applications perfectly fine. I’ve tried different cores with different games, made sure the mute toggle is off, and have selected every possible combination for the audio driver. Absolutely any recommendations/input would be so greatly appreciate as I’ve really been looking forward to using this great application. Thank you very much in advance.