Generic PC x64 Build No HDMI Audio


#1

I want to use Lakka so bad, but haven’t been able to overcome the audio issue. I have followed the recommendations in this thread:

and the Lakka troubleshooting docs.

My current issue is there are no audio devices listed in the GUI and changing config files make no difference either.

The hardware is: ZOTAC mini-PC. Quad core AMD APU, 1.5ghz, 8gb DDR3, 1TB 2.5in hard drive

Here is a link to my SSH log output:

https://drive.google.com/drive/folders/1m4we3EzhKZVo2Rg2M90qj3nH6PUb_lgU?usp=sharing

I appreciate any assistance, thanks!


#2

update:

I can hear audio out of my TV over HDMI when performing this test.

Find some wav to play :

find /storage/roms -name *.wav or get one online

wget “http://samples.mplayerhq.hu/A-codecs/wavpcm/ahh.wav” -O sound.wav Then try to play some sound with hdmi devices : aplay -D plughw:card_id,device_id

aplay -D plughw:0,3 sound.wav aplay -D plughw:0,7 sound.wav aplay -D plughw:0,8 sound.wav


#3

Can you try to make a test with nightly build ?

Thank you.

Kind regards,


#4

@gouchi I installed Lakka-Generic.x86_64-2.2-devel-20181116001312-r28230-g20d25a6.img.gz and am experiencing the same issue. Thanks!


#5
[    2.664222] ALSA device list:
[    2.664224]   No soundcards found.


Lakka:~ # lspci -v
00:00.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 16h Processor Root Complex
        Subsystem: Advanced Micro Devices, Inc. [AMD] Family 16h Processor Root Complex
        Flags: bus master, fast devsel, latency 0

00:01.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Kabini [Radeon HD 8330E] (prog-if 00 [VGA controller])
        Subsystem: Advanced Micro Devices, Inc. [AMD/ATI] Kabini [Radeon HD 8330E]
        Flags: bus master, fast devsel, latency 0, IRQ 28
        Memory at c0000000 (64-bit, prefetchable) [size=256M]
        Memory at d0000000 (64-bit, prefetchable) [size=8M]
        I/O ports at f000 [size=256]
        Memory at feb00000 (32-bit, non-prefetchable) [size=256K]
        Expansion ROM at 000c0000 [disabled] [size=128K]
        Capabilities: [48] Vendor Specific Information: Len=08 <?>
        Capabilities: [50] Power Management version 3
        Capabilities: [58] Express Root Complex Integrated Endpoint, MSI 00
        Capabilities: [a0] MSI: Enable+ Count=1/1 Maskable- 64bit+
        Capabilities: [100] Vendor Specific Information: ID=0001 Rev=1 Len=010 <?>
        Capabilities: [270] #19
        Kernel driver in use: radeon

00:01.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Kabini HDMI/DP Audio
        Subsystem: Advanced Micro Devices, Inc. [AMD/ATI] Kabini HDMI/DP Audio
        Flags: bus master, fast devsel, latency 0, IRQ 39
        Memory at feb64000 (64-bit, non-prefetchable) [size=16K]
        Capabilities: [48] Vendor Specific Information: Len=08 <?>
        Capabilities: [50] Power Management version 3
        Capabilities: [58] Express Root Complex Integrated Endpoint, MSI 00
        Capabilities: [a0] MSI: Enable+ Count=1/1 Maskable- 64bit+
        Capabilities: [100] Vendor Specific Information: ID=0001 Rev=1 Len=010 <?>
        Kernel driver in use: snd_hda_intel
        Kernel modules: snd_hda_intel



[   10.224804] input: HDA ATI HDMI HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:01.1/sound/card0/input7
[   10.242075] input: HDA ATI HDMI HDMI/DP,pcm=7 as /devices/pci0000:00/0000:00:01.1/sound/card0/input8

#6

May you provide also the complete dmesg output, Lakka system log and audio log ?

Thank you.


#7

@gouchi https://drive.google.com/open?id=1m4we3EzhKZVo2Rg2M90qj3nH6PUb_lgU


#8

Can you try to edit configuration file and change to audio_device = "hdmi:CARD=HDMI,DEV=0" then provide Lakka system log ? If it is not reworking, redo the operation with audio_device = "hdmi:CARD=HDMI,DEV=1"

Thank you.


#9

@gouchi I have made the config changes and still no audio, here is the link to the two new syslogs. https://drive.google.com/drive/folders/1m4we3EzhKZVo2Rg2M90qj3nH6PUb_lgU?usp=sharing


#10

Strange.

Can you add also the output of

grep audio_device /storage/.config/retroarch/retroarch.cfg

Thank you.


#11

@gouchi Lakka (official): devel-20181116001312-r28230-g20d25a6 (Generic.x86_64)

Lakka:~ # grep audio_device /storage/.config/retroarch/retroarch.cfg

audio_device = “”

Lakka:~ #


#12

How come you don’t have the audio_device configuration I asked you to test ?


#13

If you check the log files I uploaded after making the requested changes the config never reflects those changes. So strange, do you see anything I’m doing wrong?


#14

You need RA to be stopped before editing the configuration file otherwise it will be overwritten.

systemctl stop retroarch

then

nano /storage/.config/retroarch/retroarch.cfg

at last

retroarch -v


#15

@gouchi https://drive.google.com/file/d/1-v5qTExc4PPm6To46VRbKi0A0l1kEhHP/view?usp=sharing

I was obviously not saving the config in the right location. I made the changes and copied it to text for you to look over, still no sound. I thank you for your assistance.


#16

I got sound, I just loaded some roms back on and tested. No menu sounds, but game sounds…I’ll take it…Thanks!