Lakka USB boot RPI4?

Has anyone got Lakka booting from a USB drive on the Raspberry Pi 4?

If so, how did you do it?


1 Like

Does the RPi support it now? Last time I looked the hardware wasn’t ready

It supports it through a hybrid boot process. There must still be an SD card that contains a config file to redirect the system to boot from USB.

Here’s a exhaustively complete guide.

I tried it with Lakka some months ago, but it was too confusing because Lakka has multiple files that contribute to the boot.

With the kind of performance gains that are seen from this, it’s hard to imagine that everyone doesn’t want to do it. It’s also unclear if they will ever make USB boot explicitly available, so it may be best to figure this method out.

You can probably do a frankenstein install by flashing both SD card and USB drive and changing the cmdline to use the USB drive instead of the SD card.

It will look like SD boot -> kernel -> cmdline -> loads SYSTEM and mounts storage off of USB. Kinda cursed but could work on existing Lakka releases.

1 Like

Ok. I think I tried something like this before, but I just couldn’t find the magic combination.

My thought was that people would be clamoring for this because of the performance bump, so I was hoping that it would have been worked out by someone.

Sigh. I guess I’ll give it another shot and report back if I make any progress.


Well, it’s almost officially supported now, so this is no longer necessary.

Still in beta, but I’m going to go right for it.


They have USB support in the current eeprom bootloader (still in the beta pool), but I’m having trouble getting it to work with Lakka.

The instructions I found state that you have to copy the .elf and .dat files from a working SD card to the SSD installation, but I can’t seem to get that to work.

sudo cp /boot/*.elf /mnt/usb
sudo cp /boot/*.dat /mnt/usb

The guide I referenced is here

Any ideas?


So just tried something on a whim, copying all of the .dat and .elf files from the most current firmware release’s /boot folder to my SSD along with the Lakka image (flashed via Etcher) booted up perfectly fine

That’s great. Are you using a CRT?

I found that I wasn’t able to use the Retrotink Ultimate OR a Gert666 VGA adapter with the new Pi bootloader using Raspberry Pi OS. I think it has something to do with FKMS changes. There’s actually a bug-patched version of the bootloader on Github that has worked for others, but I couldn’t get it to work.

However, It’s possible that Lakka would still work ok as long as it isn’t using FKMS.(which I have no idea)

1 Like

I just wanted to know if anyone has done this yet?

I was able to get Raspberry Pi OS plus regular RetroArch compiled on my Pi 4 booting from an SSD via the USB 3 port. I figured that was probably the way to go at the moment since it seems to also have more cores by default, and it’s also a lot easier to compile new cores since you also have a regular OS install to work with.

IAC, just checking in here to see how Lakka fares in this respect now.

I installed the nightly build for Lakka on a 32 GB SD card and a 64 GB USB 2.0 stick. As expected the SD card worked perfectly. First boot took like a minute. USB stick also worked but resizing the file system during the first boot was very slow. It took 2 or 3 hours. After that slow first boot everything worked just fine. I recommend a lot of patience depending on the size and speed of the USB drive. I wonder why resizing took seconds on an SD card and hours on a USB stick. Maybe they get it fixed for the next stable release. I used but I recommend you get the most recent build from the link below.

Not sure. The process took a few minutes with Raspbian and RA.

Has anyone had any luck booting from an external SSD connected to USB? After a bunch of tinkering with Raspberry Pi OS I managed to get it to boot from an M.2 SATA SSD connected via an USB3 UASP adapter and install RetroPie on it. I figured I’d give Lakka a go since it looks so clean, but I’m running up against the same issues I had when trying to get a RetroPie image to work booting from the SSD.

After flashing the suggested Lakka RPi4 image to the SSD I get the typical “USB-MSD Boot Requires Newer Software” error. Next, I tried the latest nightly build, also to no avail. I also tried overwriting the .dat and .elf files in /boot with the most recent ones from, and finally I tried overwriting all files in that volume with the ones from the official repo, but both of these last attempts only lead to a grey screen when trying to boot.

Any suggestions on how to get this to work? I’m not planning on using SD cards, as the RPi4 firmware supports USB boot now.

Update: It seems that the nightly build of 2020-09-13 that AcidAngel was talking about works for USB boot. I guess I’ll tinker about with that one until the next stable release for RPi4.