Mac Mini 1,2 Lakka reinstall failure :(


#1

Hi all. I’ve drifted around the forums without registering previously and thank plenty of you for the help you’ve given without realising it!

Some months ago I managed to get Lakka (1.6 I think) installed no trouble on an old Mac Mini 1,1 but as things have progressed, I felt the need to update to the latest version, which is causing me no end of hassles. I’m getting the flower loop but I’ve managed to get it to the point where it’ll boot form live and SSH is enabled for me to be able to get logs etc and I’m hoping someone with greater knowledge than I may be able to help?

Logs:

Lakka:~ # lspci -nnk | grep -A 3 VGA 00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller [8086:27a2] (rev 03) Subsystem: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller [8086:7270] Kernel driver in use: i915 00:02.1 Display controller [0380]: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller [8086:27a6] (rev 03) Lakka:~ # aplay -L null Discard all samples (playback) or generate zero samples (capture) default:CARD=Intel HDA Intel, STAC9221 A1 Analog Default Audio Device sysdefault:CARD=Intel HDA Intel, STAC9221 A1 Analog Default Audio Device front:CARD=Intel,DEV=0 HDA Intel, STAC9221 A1 Analog Front speakers surround21:CARD=Intel,DEV=0 HDA Intel, STAC9221 A1 Analog 2.1 Surround output to Front and Subwoofer speakers surround40:CARD=Intel,DEV=0 HDA Intel, STAC9221 A1 Analog 4.0 Surround output to Front and Rear speakers surround41:CARD=Intel,DEV=0 HDA Intel, STAC9221 A1 Analog 4.1 Surround output to Front, Rear and Subwoofer speakers surround50:CARD=Intel,DEV=0 HDA Intel, STAC9221 A1 Analog 5.0 Surround output to Front, Center and Rear speakers surround51:CARD=Intel,DEV=0 HDA Intel, STAC9221 A1 Analog 5.1 Surround output to Front, Center, Rear and Subwoofer speakers surround71:CARD=Intel,DEV=0 HDA Intel, STAC9221 A1 Analog 7.1 Surround output to Front, Center, Side, Rear and Woofer speakers iec958:CARD=Intel,DEV=0 HDA Intel, STAC9221 A1 Digital IEC958 (S/PDIF) Digital Audio Output Lakka:~ # lsusb Bus 001 Device 003: ID 18a5:0302 Verbatim, Ltd Flash Drive Bus 001 Device 006: ID 05ac:0304 Apple, Inc. Mighty Mouse [Mitsumi, M1152] Bus 001 Device 004: ID 05ac:0221 Apple, Inc. Aluminum Keyboard (ISO) Bus 001 Device 002: ID 05ac:1006 Apple, Inc. Hub in Aluminum Keyboard Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub Bus 005 Device 003: ID 05ac:8240 Apple, Inc. Built-in IR Receiver Bus 005 Device 004: ID 05ac:8205 Apple, Inc. Bluetooth HCI Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub


End of DMESG (too big to c&p here…)

[INFO] Resetting shader to defaults … [INFO] [GL]: Using 4 textures. [INFO] [GL]: Loaded 1 program(s). [INFO] [GL]: Using GL_RGB565 for texture uploads. [INFO] [Font]: Using font rendering backend: freetype. [INFO] [Video]: Graphics driver did not initialize an input driver. Attempting to pick a suitable driver. [INFO] [udev]: Keyboard #0 (/dev/input/event3). [INFO] [udev]: Mouse #0 (/dev/input/event7). [INFO] [udev]: Mouse #1 (/dev/input/mouse1). [INFO] [Joypad]: Found joypad driver: “udev”. [INFO] [Video]: Found display server: null [INFO] Found shader “/tmp/shaders/bilinear.glslp” [INFO] Found shader “/tmp/shaders/nearest.glslp” [INFO] Found shader “/tmp/shaders/slang-conversion-template.glsl” [INFO] Found shader “/tmp/shaders/stock.glsl” [INFO] ALSA: Using signed 16-bit format. [INFO] ALSA: Period size: 1024 frames [INFO] ALSA: Buffer size: 2048 frames [INFO] [Menu]: Found menu display driver: “gl”. [INFO] [Font]: Using font rendering backend: freetype. [INFO] [Font]: Using font rendering backend: freetype. [INFO] [LED]: LED driver = ‘null’ 0x837e8b4 [INFO] [MIDI]: Initializing … ALSA lib /home/kivutar/Lakka-LibreELEC/build.Lakka-Generic.i386/alsa-lib-1.1.4.1/src/seq/seq_hw.c:466:(snd_seq_hw_open) open /dev/snd/seq failed: No such file or directory [ERROR] [MIDI]: snd_seq_open failed with error -2. [ERROR] [MIDI]: Initialization failed (list of input devices unavailable). [INFO] SRAM will not be saved. [INFO] Loading history file: [/storage/.config/retroarch/content_history.lpl]. [INFO] Loading history file: [/storage/.config/retroarch/content_favorites.lpl]. [INFO] Loading history file: [/storage/.config/retroarch/content_music_history.lpl]. [INFO] Loading history file: [/storage/.config/retroarch/content_video_history.lpl]. [INFO] Loading history file: [/storage/.config/retroarch/content_image_history.lpl]. [INFO] [Font]: Using font rendering backend: freetype. [INFO] [Font]: Using font rendering backend: freetype. [INFO] [KMS]: New FB: 1920x1080 (stride: 8192). Segmentation fault (core dumped)


Any pointers on what may have changed in the new version to make it fail on the same hardware? Frustratingly, I completed an install over my old Lakka install to see if that assisted, so I now can’t go back and take a look at any config files :confused: