MAME CPS1 games crash on launch

CPS1 games that used to work before now fail to launch on the latest MAME core for x86_64. I’ve tried older versions but they still crash. Log file shows no errors. Any ideas?

MAME 0.214 is broken for me too. Better use the previous version (0.212)

Do you know where I can download this? I think MAME .212 was prior to 9/16 on the buildbot.

The core i have backed up is from 2/10. Pretty sure the next update after than was the new version.

The buildbot doesn’t go back that far. Are you able to link yours?


This is a dll file. I’m using Lakka. I’ll see if I have one backed up somewhere. Thanks for helping out, though.

I wasn’t aware of the difference.

Btw, when i say 2/10 i mean October. I’m from Europe :stuck_out_tongue:

So maybe you can still find it on the buildbot.

Yeah Lakka uses .so files for cores.

And yep, totally read that as Feb 10 lol. There’s only one mame zip in the buildbot dated Oct 10, and I don’t know how to build my own, nor have linux installed to even do it in the first place. I just wish the logs would tell me what the error is.

From the command line:

Adding monitor screen0 (640 x 480) a:1.333333
Invalid video value opengl; reverting to software
SOURCE FILE: ../../../../../src/mame/drivers/cps1.cpp
NAME: 1941
DESCRIPTION: 1941: Counter Attack (World 900227)
YEAR: 1990
Assertion failed!

Program: D:\RetroArch\retroarch.exe
File: ../../../../../src/emu/tilemap.cpp, Line 950

Expression: dest.cliprect().contains(cliprect)

This was added on Sep 24, 2019 in commit ebcb2317801aa8af630308d4f7057ca8506e97d2

950 + assert(dest.cliprect().contains(cliprect));

Maybe someone with coding skills can look into this?

it’s already reported here


This is fixed now thanks to Tcamargo.

1 Like

Can confirm this works now. For some reason 1943 hangs at the machine loading screen, so I think that may be ROM related. Everything else I tried worked perfect. Thanks for all the hard work!

Apparently this fixes the issues relatet to Taito ZSG-2 and Taito G-Net as well.

I can confirm that the following games are working on Windows:

    1941: Counter Attack (Japan)
    1941: Counter Attack (World 900227)
    Captain Commando (World 911202)
    Street Fighter II: The World Warrior (World 910522)

Sega System 16A
    Shinobi (set 6, System 16A) (unprotected)
Sega System 16B
    Altered Beast (set 8) (8751 317-0078)

Taito F3 System
    Gunlock (Ver 2.30 1994/01/20)

Taito FX-1B System
    Ray Storm (Ver 2.06A)
    G-Darius (Ver 2.01J)

Taito G-NET System
    Ray Crisis (V2.03J 1998/11/15 15:43)

@Sivarticus I testet the following games as well and they are working:

Capcom Commando
    1943: The Battle of Midway (Euro)
    1943: The Battle of Midway Mark II (US)
    1943 Kai: Midway Kaisen (Japan)
1 Like

Some romsets modifications once again it seems:

bm.7k NOT FOUND (tried in 1943u 1943 1943u)
Fatal error: Required files are missing, the machine cannot be run.

Yes, in 0.211 and before it was marked as nodump, now someone was able to dump it

0.212: Decapped and dumped C8751H-88 MCU for 1943: The Battle of Midway (Euro) and clones (US), (US, Rev C), (Japan), (Japan, Rev B) and (Japan, no protection hack [Brian Troha, TeamEurope, The Dumping Union]. Hooked up MCU and removed simulation [Dirk Best]. Added Intel 8751 (6MHz) CPU3.
19th July 2019: TeamEurope - Brian bought the board and sent me the MCU for decapping. The protection of this game was reversed already a couple of years ago, but emulating the real thing is always better. I got the MCU today via post-mail and as i had some free time today, i took a look at it. At first i always try a test-dump from the MCU (maybe we are lucky and it was never locked). => Of course it was locked, just giving me FF's. As with all 8751H's i heated the top of the chip, and removed it with a screw driver. After that you just cover the eprom-area with some uv-resistent material (nail polish) and put the chip under the UV-Eraser, which will then delete the uncovered Lock-Bit. Afterwards you can read the MCU with your favorite programmer, just like it was never locked. The 4kb rom is nearly empty, just having some short binary snippets, but i already got confirmed that this dump looks good. This MCU was used in a couple of 1943 variants and should now get them all fully preserved! Most likely this will be included in the next MAME release.

The core still has some issues with Tiger Electronics games.

In the standalone 0.214 all Tiger games load and play. In the core about half of them don’t work. For instance, Addams Family works but Apollo 13 doesn’t.

Now some of these games are very recent additions to MAME. And with the previous version of the core (0.212) i thought it makes sense half of them don’t work because they were added later on maybe. But with 214 they should all work just like in the standalone. But only half of them work just like in the previous 212.

It’s almost like the core is based on an older version… If there was something wrong with my setup then none of these games would work but half of them do so there’s something else going on. There’s nothing different about the roms, they are all from the 214 romset and all work in the standalone.

Here are the logs. They seem to be the same up until the MANUFACTURER line and then it just stops without error in the games that don’t work.

NON working game:

Working game:

disable Enable Softlist in Quick Menu or
mame_softlists_enable = "disabled" in retroarch-core-options.cfg

It was already set to disabled.

Tried to enabled it to see if something changes and indeed no game works.

With it disabled half of the games work. But they should all work.