MAME roms that fail to launch

Does anyone know of a way to determine why a particular MAME rom that worked before, now doesn’t? I tried running a log of the error but no errors are output. Basically what happens is I load the rom, it crashes, and Retroarch reboots. I tried rolling back to an older version of MAME, earlier Lakka builds, and other versions of the rom file, but the problem persists. I’m currently running the 9/5 Lakka nightly on a PC.

You need to make sure your ROMs come from exactly the same ROMset as the MAME version reported by the core because MAME is very picky about that sort of thing.

Which MAME version do you using? And which ROM doesn’t work?

1 Like

Yeah I knew that, but I’ve been able to update the MAME core and the rom would still work. Right now I’m using 0.212 and the rom is RayForce. I haven’t been able to find a version of RayForce that is part of the 0.212 romset. I have other roms that I’ve used on prior versions of MAME that still work fine, like Battle Garegga and Batsugun.

Do you have its parent rom (gunlock) ?

1 Like

Yes. It won’t load on its own either.

Can you please verify if your roms are correct?
(using a tool like clrmamepro and a *.dat file from

Gunlock (Ver 2.3O 1994/01/20)

d66-01.ic2 2097152 good 58c92efa
d66-02.ic3 2097152 good dcdafaab
d66-03.ic45 1048576 good e7a4a491
d66-04.ic46 1048576 good c1c7aaa7
d66-05.ic47 1048576 good a3cefe04
d66-06.ic48 1048576 good b3d8126d
d66-07.ic49 1048576 good a6da9be7
d66-08.ic50 1048576 good 9959f30b
d66-18.ic24 262144 good 8418513e
d66-19.ic26 262144 good 95731473
d66-21.ic37 262144 good bd0d60f2
d66-22.ic23 262144 good 83dd7f9b
d66-23.ic10 262144 good 57fb7c49
d66-24.ic35 262144 good 97816378

Ray Force (Ver 2.3A 1994/01/20)

d66-25.ic35 262144 good e08653ee

Ray Force (Ver 2.3J 1994/01/20)

d66-20.ic35 262144 good 798f0254

If you have the right romsets and they don’t work, maybe there is currently an issue on those games with MAME or its libretro port. Idk since i never use it in the first place.

FWIW, the game should work properly in FBNeo.

Nope, i testet it and can confirm, that all 3 games are working with the latest mame (0.212) core.

I can see already there’s a difference in the romsets, but it still works in 0.212 MAME on my Windows desktop. The rom I have has the following files:

d66-01.ic2 58c92efa
d66-02.ic3 dcdafaab
d66-03.ic45 e7a4a491
d66-04.ic46 c1c7aaa7
d66-05.ic47 a3cefe04
d66-06.ic48 b3d8126d
d66-07.ic49 a6da9be7
d66-08.ic49 9959f30b
d66-18.ic24 8,418,513th
d66-19.ic26 95731473
d66-21.ic37 bd0d60f2
d66-22.ic23 83dd7f9b
d66-23.ic10 57fb7c49
d66-24.ic35 97816378

Mine has two “ic49” files where yours has ic49 and ic50. But like I said it still works. I think I might try a fresh install of Lakka.

Worst case I just play the Saturn version Galactic Attack.

@Sivarticus Then you have a pre-0.210 rom.
In the 0.210 release they renamed the ic49 rom in ic50 to avoid duplicate.
Try to rename this:

name crc32
d66-08.ic49 9959f30b
d66-08.ic50 9959f30b

@ImnoTapLumber way ahead of you lol… tried and failed.

Fresh install worked. It now loads like normal. Not really sure what fixed it, but if anyone else sees this post, might work for you too.

1 Like

@Sivarticus I’m glad it worked out. I was really out of ideas.

If you sometime find out what was wrong let us know :slight_smile:

I figured out what was wrong. So I guess MAME doesn’t like it if you have roms sorted into subfolders?

I had the rom saved as such - storage/roms/Arcade/RayForce/

Doesn’t work if you store it this way. Once I moved it to just the Arcade folder, it loaded perfect. Now I know.

1 Like