Manually add cores?

I’ve been slowly, but surely, getting my Lakka system up and running thanks to some very helpful people here :). So before I go further, thanks to all who have helped me so far!

Lately I’ve been working on my Arcade roms. I don’t have the benefit of having a particular rom-set that works perfectly with any certain core. I’ve managed to create a combined mame2003/fba playlist as I’ve figured out which roms I have work with which emulator. But I still have a number of roms that don’t work with either. After quite a bit of searching, I haven’t found a place where I can download different cores that I can manually install. I’ve found mentions of different mame versions (such as 2010), but I can’t find where to download them. Can anyone point me to where I can get these? I’d like to give these new cores a try with the roms that are still giving me trouble.

Hmmm…I managed to find a menu within Lakka where I could select and download some cores. I downloaded a few (MAME 2014 among them), but I made the mistake of backing out of that menu to test a few things, but now I can’t get back into it. I got into the menu when trying to run a rom and then it took me to that menu. But since I downloaded a few, it attached one of those cores to that file, and it will no longer give me choices to download. How can I get back to that menu? That should solve my “manually add cores?” question :).

Which version of Lakka are you using ? Because we removed the option to download core.

Every core which running well is baked per platform so you don’t need to manually add it.

If you need a special one, please open an issue so that we provide it for everyone.

I’m not sure. I poked through my Lakka installation and couldn’t find anything that would tell me. I did find one of the downloads I did back in August when I did the install. However I’m not 100% it was the exact download I used. But at any rate, it is a pretty good shot. Here is the filename of the download: Lakka-Generic.i386-devel-20160717204739-r21527-g4656d16.img

I’m not sure which core I need. That is why I was really glad to find the option to download cores. I need to do some testing.

I figured out how to get to the menu to download cores. I set up a way to repeat the conditions of how I got to it in the first place. I first saw the menu when it appeared Lakka didn’t know how to read a certain file. When I downloaded a core from that menu and backed out, that core was then assigned to that file and I couldn’t get to the download menu again. So what I did was take a random file from my computer and copied it into one of my rom folders. Then I got into Lakka and tried to “run” it. That brought up the menu for me again. So if my version of Lakka already has the option for downloading cores removed, then I’m sure you’ll want to know about this so you can address it in a future build.

Bad news for my (initial!..haven’t gone through thoroughly yet) testing though…the new cores I downloaded (mame2010, mame2014, mess, etc.) haven’t been able to play the few roms I’ve tried. On the plus side, I’ve managed to get the roms that didn’t work at all with mame2003 or fba to at least try to work with a couple of these cores. They only get to a loading screen when the rom starts, and then it stops. It’s a start though :).

Hmm, so, it’s not supported to add for instance mame (current) or mame2014 to Lakka ? Been wondering how to do this. (just copying them to /storage/cores from ?)

Just wondering. I’ll wait anyway :slight_smile:

I couldn’t find an “official” way to do it. I couldn’t find any of those cores that I could download straight out from anywhere. And the workaround that I found to download them appears to be a feature that might not have been completely removed from Lakka for the current build I have installed (they did mention it was removed). So hopefully I did some good finding this alternate way to download them so they can address it LOL :).

Maybe you downgraded the OS, instead of upgrading it?

I’m not going to say that I didn’t…my ignorance and still being new to Lakka cautions me against stating that as a fact LOL. But I definitely didn’t set out to do anything of the sort. So with that thought in mind, I’d say HIGHLY unlikely :).

In fact I forgot to remove that Download Cores menu that is in the Load Cores menu in advanced mode.

Please don’t use it. Cores from the buildbot often have incompatibility issues with Lakka.

Read the documentation about Arcade roms on our website. And try to use FBA, not MAME for now. Choose the right romset for FBA, with the right version, and everything will work.

I was able to manually add them by looking for the .so core files from the windows Retroarch GitHub or you can directly download lakka cores from the