Manually Configuring Resolution

Hello everyone.

I’m running Lakka on a PC, with Intel HD graphics hardware. When I connect the device to a 4K display, it automatically scales up to the full resolution of the display. I would like to force it down to 1080p for better performance. Can anyone provide instruction?

Thanks.

Here is the system log, in case that helps:

Lakka:~ # systemctl stop retroarch.service ; retroarch -v RetroArch [INFO] :: === Build ======================================= Capabilities: MMX MMXEXT SSE1 SSE2 SSE3 SSSE3 SSE4 SSE4.2 Built: Sep 27 2016 RetroArch [INFO] :: Version: 1.3.6 RetroArch [INFO] :: Git: 03241bf RetroArch [INFO] :: ================================================= RetroArch [INFO] :: Looking for config in: “/storage/.config/retroarch/retroarch.cfg”. RetroArch [INFO] :: Config: loading config from: /storage/.config/retroarch/retroarch.cfg. RetroArch [INFO] :: Resetting undo buffers. RetroArch [INFO] :: Environ SET_PIXEL_FORMAT: RGB565. RetroArch [INFO] :: Version of libretro API: 1 RetroArch [INFO] :: Compiled against API: 1 RetroArch [INFO] :: Set audio input rate to: 29970.03 Hz. RetroArch [INFO] :: Found shader “/usr/share/common-shaders/bilinear.glslp” RetroArch [INFO] :: Found shader “/usr/share/common-shaders/nearest.glslp” RetroArch [INFO] :: Found shader “/usr/share/common-shaders/stock.glsl” RetroArch [INFO] :: Video @ 960x720 RetroArch [INFO] :: Starting threaded video driver … RetroArch [INFO] :: [DRM]: Found 3 connectors. RetroArch [INFO] :: [DRM]: Connector 0 connected: no RetroArch [INFO] :: [DRM]: Connector 0 has 0 modes. RetroArch [INFO] :: [DRM]: Connector 1 connected: yes RetroArch [INFO] :: [DRM]: Connector 1 has 48 modes. RetroArch [INFO] :: [DRM]: Connector 1 assigned to monitor index: #1. RetroArch [INFO] :: [DRM]: Connector 2 connected: no RetroArch [INFO] :: [DRM]: Connector 2 has 0 modes. RetroArch [INFO] :: [DRM]: Mode 0: (3840x2160) 3840 x 2160, 30 Hz RetroArch [INFO] :: [DRM]: Mode 1: (4096x2160) 4096 x 2160, 24 Hz RetroArch [INFO] :: [DRM]: Mode 2: (4096x2160) 4096 x 2160, 24 Hz RetroArch [INFO] :: [DRM]: Mode 3: (3840x2160) 3840 x 2160, 30 Hz RetroArch [INFO] :: [DRM]: Mode 4: (3840x2160) 3840 x 2160, 25 Hz RetroArch [INFO] :: [DRM]: Mode 5: (3840x2160) 3840 x 2160, 24 Hz RetroArch [INFO] :: [DRM]: Mode 6: (3840x2160) 3840 x 2160, 24 Hz RetroArch [INFO] :: [DRM]: Mode 7: (1920x1080) 1920 x 1080, 60 Hz RetroArch [INFO] :: [DRM]: Mode 8: (1920x1080) 1920 x 1080, 60 Hz RetroArch [INFO] :: [DRM]: Mode 9: (1920x1080i) 1920 x 1080, 60 Hz RetroArch [INFO] :: [DRM]: Mode 10: (1920x1080i) 1920 x 1080, 60 Hz RetroArch [INFO] :: [DRM]: Mode 11: (1920x1080) 1920 x 1080, 50 Hz RetroArch [INFO] :: [DRM]: Mode 12: (1920x1080i) 1920 x 1080, 50 Hz RetroArch [INFO] :: [DRM]: Mode 13: (1920x1080) 1920 x 1080, 30 Hz RetroArch [INFO] :: [DRM]: Mode 14: (1920x1080) 1920 x 1080, 30 Hz RetroArch [INFO] :: [DRM]: Mode 15: (1920x1080) 1920 x 1080, 25 Hz RetroArch [INFO] :: [DRM]: Mode 16: (1920x1080) 1920 x 1080, 24 Hz RetroArch [INFO] :: [DRM]: Mode 17: (1920x1080) 1920 x 1080, 24 Hz RetroArch [INFO] :: [DRM]: Mode 18: (1680x1050) 1680 x 1050, 60 Hz RetroArch [INFO] :: [DRM]: Mode 19: (1600x900) 1600 x 900, 60 Hz RetroArch [INFO] :: [DRM]: Mode 20: (1280x1024) 1280 x 1024, 75 Hz RetroArch [INFO] :: [DRM]: Mode 21: (1280x1024) 1280 x 1024, 60 Hz RetroArch [INFO] :: [DRM]: Mode 22: (1440x900) 1440 x 900, 60 Hz RetroArch [INFO] :: [DRM]: Mode 23: (1366x768) 1366 x 768, 60 Hz RetroArch [INFO] :: [DRM]: Mode 24: (1280x800) 1280 x 800, 60 Hz RetroArch [INFO] :: [DRM]: Mode 25: (1152x864) 1152 x 864, 75 Hz RetroArch [INFO] :: [DRM]: Mode 26: (1280x720) 1280 x 720, 60 Hz RetroArch [INFO] :: [DRM]: Mode 27: (1280x720) 1280 x 720, 60 Hz RetroArch [INFO] :: [DRM]: Mode 28: (1280x720) 1280 x 720, 50 Hz RetroArch [INFO] :: [DRM]: Mode 29: (1024x768) 1024 x 768, 75 Hz RetroArch [INFO] :: [DRM]: Mode 30: (1024x768) 1024 x 768, 70 Hz RetroArch [INFO] :: [DRM]: Mode 31: (1024x768) 1024 x 768, 60 Hz RetroArch [INFO] :: [DRM]: Mode 32: (832x624) 832 x 624, 75 Hz RetroArch [INFO] :: [DRM]: Mode 33: (800x600) 800 x 600, 75 Hz RetroArch [INFO] :: [DRM]: Mode 34: (800x600) 800 x 600, 72 Hz RetroArch [INFO] :: [DRM]: Mode 35: (800x600) 800 x 600, 60 Hz RetroArch [INFO] :: [DRM]: Mode 36: (720x576) 720 x 576, 50 Hz RetroArch [INFO] :: [DRM]: Mode 37: (720x576i) 720 x 576, 50 Hz RetroArch [INFO] :: [DRM]: Mode 38: (720x480) 720 x 480, 60 Hz RetroArch [INFO] :: [DRM]: Mode 39: (720x480) 720 x 480, 60 Hz RetroArch [INFO] :: [DRM]: Mode 40: (720x480i) 720 x 480, 60 Hz RetroArch [INFO] :: [DRM]: Mode 41: (720x480i) 720 x 480, 60 Hz RetroArch [INFO] :: [DRM]: Mode 42: (640x480) 640 x 480, 75 Hz RetroArch [INFO] :: [DRM]: Mode 43: (640x480) 640 x 480, 73 Hz RetroArch [INFO] :: [DRM]: Mode 44: (640x480) 640 x 480, 67 Hz RetroArch [INFO] :: [DRM]: Mode 45: (640x480) 640 x 480, 60 Hz RetroArch [INFO] :: [DRM]: Mode 46: (640x480) 640 x 480, 60 Hz RetroArch [INFO] :: [DRM]: Mode 47: (720x400) 720 x 400, 70 Hz RetroArch [INFO] :: Found GL context: kms RetroArch [INFO] :: Detecting screen resolution 3840x2160. RetroArch [INFO] :: [EGL]: EGL version: 1.4 RetroArch [INFO] :: [EGL]: Current context: 0x7f3ae8121ca0. RetroArch [INFO] :: [KMS]: New FB: 3840x2160 (stride: 15360). RetroArch [INFO] :: [GL]: Vendor: Intel Open Source Technology Center, Renderer: Mesa DRI Intel® Haswell Desktop . RetroArch [INFO] :: [GL]: Version: 3.0 Mesa 11.2.0-rc1. RetroArch [INFO] :: GL: Using resolution 3840x2160 RetroArch [INFO] :: [GL]: Default shader backend found: glsl. RetroArch [INFO] :: [Shader driver]: Using GLSL shader backend. RetroArch [INFO] :: Checking GLSL shader support … RetroArch [WARN] :: [GL]: Stock GLSL shaders will be used. RetroArch [INFO] :: Found GLSL vertex shader. RetroArch [INFO] :: Found GLSL fragment shader. RetroArch [INFO] :: Linking GLSL program. RetroArch [INFO] :: Found GLSL vertex shader. RetroArch [INFO] :: Found GLSL fragment shader. RetroArch [INFO] :: Linking GLSL program. RetroArch [INFO] :: Found GLSL vertex shader. RetroArch [INFO] :: Found GLSL fragment shader. RetroArch [INFO] :: Linking GLSL program. RetroArch [INFO] :: Found GLSL vertex shader. RetroArch [INFO] :: Found GLSL fragment shader. RetroArch [INFO] :: Linking GLSL program. RetroArch [INFO] :: Found GLSL vertex shader. RetroArch [INFO] :: Found GLSL fragment shader. RetroArch [INFO] :: Linking GLSL program. RetroArch [INFO] :: [GL]: Using 4 textures. RetroArch [INFO] :: [GL]: Loaded 1 program(s). RetroArch [INFO] :: [GL]: Using GL_RGB565 for texture uploads. RetroArch [INFO] :: Using font rendering backend: freetype. RetroArch [INFO] :: Graphics driver did not initialize an input driver. Attempting to pick a suitable driver. RetroArch [WARN] :: [udev]: Couldn’t open any keyboard, mouse or touchpad. Are permissions set correctly for /dev/input/event*? RetroArch [INFO] :: Found joypad driver: “udev”. RetroArch [INFO] :: ALSA: Using signed 16-bit format. RetroArch [INFO] :: ALSA: Period size: 384 frames RetroArch [INFO] :: ALSA: Buffer size: 1536 frames RetroArch [INFO] :: Found menu display driver: “menu_display_gl”. RetroArch [INFO] :: Using font rendering backend: freetype. RetroArch [INFO] :: Using font rendering backend: freetype. RetroArch [INFO] :: SRAM will not be saved. RetroArch [INFO] :: Loading history file: [/storage/.config/retroarch/content_history.lpl]. RetroArch [INFO] :: Loading history file: [/storage/.config/retroarch/content_music_history.lpl]. RetroArch [INFO] :: Loading history file: [/storage/.config/retroarch/content_video_history.lpl]. RetroArch [INFO] :: Loading history file: [/storage/.config/retroarch/content_image_history.lpl]. RetroArch [INFO] :: [KMS]: New FB: 3840x2160 (stride: 15360). RetroArch [INFO] :: [KMS]: New FB: 3840x2160 (stride: 15360).

In your retroarch.cfg, there are settings for video_fullscreen_x and video_fullscreen_y. If you set those to 1920 and 1080, respectively, it should attempt to use that resolution when running in exclusive fullscreen.

Thank you for the response.

I issued the following command: nano /storage/.config/retroarch/retroarch.cfg

changed these values: video_fullscreen_x = “1920” video_fullscreen_y = “1080”

and reset the system. The resolution is still 3840x2160.

Thoughts?

Did you stop retroarch before editing the configuration file ?

In that case, I think you might have to mess with the boot options. Gouchi or kivutar would have to help you with that.

gouchi, yes I stopped the retroarch before editing the file. I also checked to ensure the configuration wasn’t overwritten after reboot.

huntertek, I appreciate the reply.

You can try to set video parameters into the cmdline for the connector and resolution you want.

Thanks for pointing me toward the documentation.

I did this in order to determine which display connector to configure:

Lakka:~ # for p in /sys/class/drm//status; do con=${p%/status}; echo -n "${con#/card?-}: "; cat $p; done HDMI-A-1: connected HDMI-A-2: disconnected VGA-1: disconnected

I then tried this, but it didn’t work:

Lakka:~ # systemctl stop retroarch Lakka:~ # video=HDMI-A-1:[email protected] Lakka:~ # systemctl start retroarch

Based on some other documentation, I tried putting the video= parameters in the extlinux.conf file, but that file is read-only.

Lakka:~ # nano /flash/extlinux.conf

I appreciate all the responses.

Issue resolved.

I rebuilt by Lakka machine with the latest x86_64 build: devel-20161106231917-r21640-ge218f0f.

Afterwards, I was able to change these lines in the retroarch.cfg video_fullscreen_x = “1920” video_fullscreen_y = “1800”

[email protected] now works on my 4K TV.

Thanks, huntertek and gouchi!

Weird. I wonder why it only worked after the update. Oh well, whatever :slight_smile:

A post was merged into an existing topic: I can only start new topics in near-empty categories

I just installed Lakka 2.3.2 to Raspberry Pi 4 that is connected to 4k TV.

Games work well and with good speed but the problem is Lakka’s own user interface (XMB) which is slow. I’d like it to be 60 FPS but it’s about 16 FPS. I’ve already disabled Menu Shader Pipeline.

I tried setting fixed values to Settings > Video > Fullscreen Mode > Fullscreen Width & Height and that helps but it also affects aspect ratio of games so I cannot use it.

Any ideas?