New CRT shader from Guest + CRT Guest Advanced updates

Hi, I am kinda new to retroarch. Not a newb to emulation tho. I am wondering, where do I place the update? I have Sonkun’s shaders installed and working properly but uncertain about where I need to place the presets. Sorry for such a simple question

1 Like

I know it’s early days still but instead of this:

I’m seeing this:



So there’s a black halo?(shadow?) around the glowing phosphors. I think this might negate some of the blending properties of the effect even though you’ll still get to see the barely visible mask.

For the proper effect the phosphor must glow and blend on top of the energized mask with no black separation between the transition by default unless it is artificially added in case one would want more sharpness.

I think if you nail this, you might even be able to get away with less blur on the emulated phosphors themselves while still having smoother edges than what might have been possible before so the net effect might be a sharper, clearer image due to lower phosphor blur but smoother edges due to edges gradually fading into the inactive phosphor colour instead of a sharp black drop-off.

1 Like

One question: should this new effect be uniform all around the screen, or should it be stronger near actually illuminated phosphors? I would think it’d be the latter, and judging from pictures from the CRT thread in this forum, it would seem to bear out, but I can’t really say without an actual CRT in front of me, and even then I suspect other factors may come into play depending on the CRT and how it’s calibrated. And how would it play with the existing Glow and Halation parameters?

1 Like

I think this is your answer right here:

It’s the unenergized phosphors that can be “passively” visible so there’s no energy being applied to those to create any excitement of the phosphors and thus difference in light output. So of course it’s going to be uniform.

This is what Magic Glow already does brilliantly.

1 Like

Into the crt folder in the shaders_slang main folder. You don’t copy the base folder in the zip, but the folder’s content and you are good to go.

Yeah, i noticed it also, i guess this looks better:


Place the sonkun folder right into the shaders_slang folder and you should be good to go. Welcome to the forum by the way. If you have any other questions you can send to my thread as well right here:

1 Like

We both replied to him at the same time lol.

Also @guest.r while I’m at and since it seems you’re working on another update I have to bring this up again. If it’s possible can you try to make it to where I can place the new upgraded grade shader into my presets where I usually always have it placed? I know you said that the after glow pass wouldn’t affect anything and that I could just place grade above it, I tried that and it indeed works that way but I really don’t want to see two different types of color managing shaders in my presets.

I think it’s a issue with the LUT or something when I try to replace the “pre-shaders-afterglow” pass with grade, not exactly sure. If it’s not possible I’ll just leave this topic alone going forward.


New Release Version (2023-07-13-r1):

Notable changes:

  • Base (black) Mask strength feature added

Download link:


I think i’ll need some extra time to update the new grade version like the older one was adapted. I guess it’s best to put it on my schedule.

1 Like

Definitely, looks better. Great job!

This one and the next image appear to have a very slight black separation and possibly a very slight black outline between the inactive mask and the boundary of the phosphor glow but it could just be me.



It’s not visible at all to me in these red transitions though.


This shows the combination of Magic Glow and the new Base (Black) Mask Strength feature quite well.


The area to the left of the green character (in the original image) seems to display some afterglow.

Thanks a lot @guest.r! I’m looking forward to tweaking and playing around with this new setting!

Before this, one of the ways to get this type of effect albeit improperly was to increase the gamma so that areas which would normally be dark now show visible mask the downside of this would have been washing out the mask on the brighter end. Now we can have nicer edge transitions and fades/blends to near black without suffering this penalty.

I want to see the effect this has on previously very sharp, harsh presets.

Thanks again for your hard work and dedication to the community!


No problem at all. I’m just glad you’ll consider adding it in that way at a certain point. I wasn’t planning to do another update until I get that new grade in but in the mean time I’ll see what this new update is about that you just posted. Thank you for always making this shader better.

Hmm, there seems to be an issue with how this new feature interacts with Magic Glow around the edges of pixels. To best illustrate the problem, here’s the Base Mask strength parameter set to maximum, with Magic Glow enabled and set to its default value of 0.08:

Here’s the same, but using regular Glow:


Maybe it’s the same thing I was noticing just amplified. It could be one cancelling the other. Remember, the two are supposed to either mix (additively) or be one in front (or on top of the other). It is quite possible that depending on the math and implementation that one is cancelling the other.

Remember both algorithms are trying to determine the final output colour of basically the same pixels. Maybe some tweaks to the way both are blended might need to take place?

Regular Glow doesn’t show the same issue but regular Glow doesn’t use the emulated phosphors exclusively to generate its effect.

It just lights extra pixels even in between the mask and regardless of the phosphor colours instead of exclusively allowing the RGB mix of the phosphor colours to determine the colour.

One possible workaround in the meantime could be to not “abuse” the setting until this cancellation is visible. Remember this is supposed to be something that’s very subtle and hardly ever visible. Perhaps testing at much lower levels of Base (Black) Mask strength might reveal a much more acceptable level of cancellation or maybe none that is visible at all?

If that be the case then there’s no need for change in the shader. So maybe try balancing Magic Glow and Base (Black) Mask a bit until you can barely see the unexcited Mask and there’s no black halo between the transitions and perhaps you might have your sweetspot right there.

Testing it further, it’s weirder than I thought. The black “halo” doesn’t change size or shape no matter what you change in the Glow parameters (it only seems to respond to Scanline and Sharpness changes, which change the shape of pixels, so that’s to be expected). Also, even if you set Glow Strength to 0 (which should disable it altogether), it still appears so long as Magic Glow is enabled, and immediately goes away when you disable it (i.e. enable regular Glow). Even stranger still is that the Magic Glow Mask Strength parameter appears tied to the Base Mask parameter, so if you lower it all the way down, you can no longer see the phosphors in the Base Mask, although raising the Base Mask parameter still brightens up the black areas of the screen. Not sure if that’s intended.

As for striking a balance, as it is, you basically have to have Base Mask set to 0.02 or 0.03 at most to not really notice the “halo”.

Anyway, here’s a shot using negative Glow values (also testing out the NES color decode shader, so that’s why the colors look different). I think it looks alright:


Interesting that you got it to work because I was just about to type that I concur with your findings. It’s really weird in my testing so far if you leave everything else at defaults and just enable Magic Glow and start to turn Base (Black) Mask strength up.

So I guess you need to be using negative glow values only for this to work then?

Does the NES Colour Palette have anything to do with it?

Okay, just realized that the black halo is exactly the area that gets affected by glow when you switch from Magic Glow to Ordinary Glow.

Changing (Magic) Glow Strength from +0.08 to -0.08 didn’t help.

I’m using the Sony CXA2025AS Palette in Mesen.

When I switch the Palette to Raw it seems to go away but I’ve never used the NES color decoder shader so I guess I have to prepend that for everything to work properly at least in Mesen.

So right now my colours are completely off. Maybe the halo only affects Black. There’s currently no black on my screen due to the Raw Palette being enabled without the decoder.


When I presented the nes-color-decoder.slang the black halo came back. Again when I switch Magic Glow to Ordinary Glow the glow fills almost the identical area as the black halo.

What I can say is that using the Ordinary Glow with negative values seems to be providing the effect that I was expecting. With positive values not so much due to the coloured pixels infiltrating the mask.

Definitely looking good with negative values. Even with the default low positive values the horizontal spread doesn’t seem enough to negatively impact the mask that much and you definitely don’t want to go overboard on the negative values either or you’ll end up with a “heatsink”.

So Magic Glow + Base (Black) Mask Strength seems to be a no go but it probably isn’t needed because Ordinary Glow works fine with it, especially negative values.

So probably nothing to fix. In any case this new parameter can actually replace the Magic Glow in a way that’s more realistic in my opinion so the two don’t necessarily need to be active at the same time.

Thanks again @guest.r!

No, the color decode shader has nothing to do with it. Negative Glow Strength values only do anything different if you use regular Glow. From what I can tell, Magic Glow does the same thing with positive and negative values. In other words, there’s three types of Glow:

  1. Regular Glow (positive values)
  2. Regular Glow (negative values)
  3. Magic Glow (positive and negative values do the same thing)

Base Mask works just fine with the first two. It’s Magic Glow that has the black “halo” problem regardless of what value you use, whether it’s positive, negative or even 0.

1 Like

So it seems like all’s well that ends well then. Looking forward to another one of @RetroGames4K’s CRT vs CRT Shader challenges because this was the one missing feature from shaders that always gave it away for me.


Oh sweet, I’ve been really wanting something like this!

Unfortunately it seems to not work correctly with slots, as they’re being displayed over the phosphor pattern. Realistically, the slot mask sits behind the phosphor strips and is only visible when it blocks the electron beam, and not when the phosphors are lit externally. Hopefully it’s easy enough to fix the order of the effects to address this.

Also suggesting naming the setting something like “Unlit Phosphor Level” or “Ambient Phosphor Level” instead.

After further testing it seems the green strip isn’t visible enough at a reasonable low brightness (near black rather than gray) like it appears in the real CRT photos. Could you consider biasing green at lower levels, or maybe break out the setting for each phosphor color?

1 Like

Haven’t tested Slot Masks yet but I’m really looking forward to. Hope it gets sorted out.


I didn’t observe this in my testing. Can you provide a screenshot to better illustrate? Slot Mask seems fine to me so far.

I think I’ve seen it before on the shaders, and works on slotmasks too, to achieve that effect I think is raising black level up if I remember, but I’m not sure if it’s that option or another.