Nintendo Switch Lakka "Failed to load boot device or script!" error

I have been trying to get Lakka to run on my hacked Nintendo Switch for some time and have not been able to get it to work. I am getting the error that is seen in the picture. I am running Lakka 4.3, the latest version of Hetake, Atmosphere, and the latest firmware for the Switch. Everything else works. I have used multiple SD cards, including a 128GB Samsung EVO, which is formatted to FAT32. I have no idea what I could be doing wrong, and nothing I’ve tried has worked. My hetake version on my bootloader and on my Switch are both 6.0.4.

The last time I was able to get Lakka to work was before I updated my firmware. I have tried multiple versions of Lakka going back to 3.4, and none work.

If you have any suggestions whatsoever to get Lakka to work on my Switch, or if you have seen this error before and have found a way to resolve it, please let me know.

Thank you in advance for any assistance you might be able to provide!