No pcsx2 folder

Hello dear libretro community

I have a problem with the Playstation 2 emulator, it is not recognized. When I click Core -> Manage Core -> Sony Playstation PCSX2, it says the pcsx2/bios folder does not exist. I downloaded it here https://pcsx2.net/downloads/ and created in /storage/system/pcsx2 with no success, then I created it in /storage/core/pcsx2 but also without success, Lakka continues to say that the pcsx2/bios folder does not exist. There are also no log files in the /storage/logfiles folder that I could look for.

Do you know how to solve the problem?

Kind regards Timm

1 Like

The BIOS files are not included in the emulator download, you will have to locate a set and put them in the “system/PCXS2/bios” folder.

The “bios” folder doesn’t even exist in the distribution, which is the only reason you are getting the error. RA only checks for the folder, it doesn’t check for any BIOS roms.

1 Like

Hello Duimon

Yes, I knew that the BIOS files are not included with Lakka, so I downloaded the folder structure from https://pcsx2.net/downloads/ and I DUMPED THE BIOS FROM MY OWN CONSOLE IN ACCORDANCE WITH MY LOCAL LAWS.

After downloading the BIOS files, I moved them into the BIOS folder under the PCSX2 folder structure.

Then I tried the folder structure under /storage/system/pcsx2 without success, and then i tried it in /storage/core/pcsx2 also without success.

Either he doesn’t find the pcsx2 folder or doesn’t invent the BIOS folder in the PCSX2 folder.

Log files would also be helpful, but unfortunately the folder /storage/logfiles is empty, but why is the folder empty?

1 Like

You have to manually create the bios folder and put the bios files in it. You should also not post links of any kind for roms, including bios roms.

Or maybe you meant something else by “invent”.

For logs, you have to turn on logging in the RA settings. It is not on by default. Although in this case it would be a short log that ends with the error you’ve already seen.

Okay, I guess I didn’t explain that very well, so I took pictures

picture1.1 picture1.2 picture2.1 picture2.2

I hope the problem is explained better now

On Windows at least, not all bios’ go into their own core folder, they just reside in the system folder:

My bad, those ps1 bios, ps2 is in it’s own folder!

The “doc”: https://docs.libretro.com/library/pcsx2/

does mention that if you are on a case sensitive system to name them all lowercase, is that Lakka?

does mention that if you are on a case sensitive system to name them all lowercase, is that Lakka?

Yes.

Documentation

If you’re on a case-sensitive OS, make sure both pcsx2 and bios folders are lowercase.

Hello SLOTH and Gouchi

I wrote everything lowercase and the bios files are all in a bios folder which is in a pcsx2 folder I know the documentation at https://docs.libretro.com/library/pcsx2/, it also says that the pcsx2 folder must be in the system folder, but the system does not recognize this folder.

Can you see anything in the pictures? the path and the upper and lower case letters are also to be marked on the pictures

maybe the pictures will help better than what I write