No Sound from the HDMI on my GT 710 with Laka 2.2


#1

I have scoured the forums and have tried every manual configuration possible in the config.txt file but i never get any sound passed out to the tv attached on the HDMI output. There is never any issue with video. It’s worth noting that in the GUI i am never given any options for audio devices, hence why I have been editing the config file manually.

The PC is a core 2 DUO, 4GB ram, GT 710 and i’m running the 64 bit version of Lakka.

Below are all the logs i could pull of the PC.

/flash$ systemctl stop retroarch.service ; retroarch -v [INFO] RetroArch 1.7.5 (Git b55ed9e) [INFO] === Build ======================================= Capabilities: MMX MMXEXT SSE1 SSE2 SSE3 SSSE3 Built: Dec 22 2018 [INFO] Version: 1.7.5 [INFO] Git: b55ed9e [INFO] ================================================= [INFO] Environ SET_PIXEL_FORMAT: RGB565. [INFO] Redirecting save file to “/storage/savefiles/.srm”. [INFO] Redirecting savestate to “/storage/savestates/.state”. [INFO] Version of libretro API: 1 [INFO] Compiled against API: 1 [INFO] [Audio]: Set audio input rate to: 29970.03 Hz. [INFO] [Video]: Video @ fullscreen [INFO] [Video]: Starting threaded video driver … [INFO] [DRM]: Found 3 connectors. [INFO] [DRM]: Connector 0 connected: no [INFO] [DRM]: Connector 0 has 0 modes. [INFO] [DRM]: Connector 1 connected: yes [INFO] [DRM]: Connector 1 has 37 modes. [INFO] [DRM]: Connector 1 assigned to monitor index: #1. [INFO] [DRM]: Connector 2 connected: no [INFO] [DRM]: Connector 2 has 0 modes. [INFO] [DRM]: Mode 0: (1920x1080) 1920 x 1080, 60 Hz [INFO] [DRM]: Mode 1: (1920x1080) 1920 x 1080, 60 Hz [INFO] [DRM]: Mode 2: (1920x1080) 1920 x 1080, 60 Hz [INFO] [DRM]: Mode 3: (1920x1080i) 1920 x 1080, 60 Hz [INFO] [DRM]: Mode 4: (1920x1080i) 1920 x 1080, 60 Hz [INFO] [DRM]: Mode 5: (1920x1080) 1920 x 1080, 50 Hz [INFO] [DRM]: Mode 6: (1920x1080) 1920 x 1080, 50 Hz [INFO] [DRM]: Mode 7: (1920x1080i) 1920 x 1080, 50 Hz [INFO] [DRM]: Mode 8: (1920x1080) 1920 x 1080, 30 Hz [INFO] [DRM]: Mode 9: (1920x1080) 1920 x 1080, 30 Hz [INFO] [DRM]: Mode 10: (1920x1080) 1920 x 1080, 24 Hz [INFO] [DRM]: Mode 11: (1920x1080) 1920 x 1080, 24 Hz [INFO] [DRM]: Mode 12: (1680x1050) 1680 x 1050, 60 Hz [INFO] [DRM]: Mode 13: (1400x1050) 1400 x 1050, 60 Hz [INFO] [DRM]: Mode 14: (1600x900) 1600 x 900, 60 Hz [INFO] [DRM]: Mode 15: (1280x1024) 1280 x 1024, 75 Hz [INFO] [DRM]: Mode 16: (1280x1024) 1280 x 1024, 60 Hz [INFO] [DRM]: Mode 17: (1440x900) 1440 x 900, 60 Hz [INFO] [DRM]: Mode 18: (1280x800) 1280 x 800, 60 Hz [INFO] [DRM]: Mode 19: (1152x864) 1152 x 864, 75 Hz [INFO] [DRM]: Mode 20: (1280x720) 1280 x 720, 60 Hz [INFO] [DRM]: Mode 21: (1280x720) 1280 x 720, 60 Hz [INFO] [DRM]: Mode 22: (1280x720) 1280 x 720, 60 Hz [INFO] [DRM]: Mode 23: (1280x720) 1280 x 720, 50 Hz [INFO] [DRM]: Mode 24: (1024x768) 1024 x 768, 75 Hz [INFO] [DRM]: Mode 25: (1024x768) 1024 x 768, 70 Hz [INFO] [DRM]: Mode 26: (1024x768) 1024 x 768, 60 Hz [INFO] [DRM]: Mode 27: (832x624) 832 x 624, 75 Hz [INFO] [DRM]: Mode 28: (800x600) 800 x 600, 75 Hz [INFO] [DRM]: Mode 29: (800x600) 800 x 600, 60 Hz [INFO] [DRM]: Mode 30: (720x576) 720 x 576, 50 Hz [INFO] [DRM]: Mode 31: (720x480) 720 x 480, 60 Hz [INFO] [DRM]: Mode 32: (720x480) 720 x 480, 60 Hz [INFO] [DRM]: Mode 33: (640x480) 640 x 480, 75 Hz [INFO] [DRM]: Mode 34: (640x480) 640 x 480, 60 Hz [INFO] [DRM]: Mode 35: (640x480) 640 x 480, 60 Hz [INFO] [DRM]: Mode 36: (720x400) 720 x 400, 70 Hz [INFO] [GL]: Found GL context: kms [INFO] [GL]: Detecting screen resolution 1920x1080. [INFO] [EGL] Found EGL_EXT_platform_base, trying eglGetPlatformDisplayEXT [INFO] [EGL]: EGL version: 1.4 [INFO] [EGL]: Current context: 0x7f1a6803ac40. [INFO] [KMS]: New FB: 1920x1080 (stride: 7680). [INFO] [GL]: Vendor: nouveau, Renderer: Gallium 0.4 on NV106. [INFO] [GL]: Version: 3.0 Mesa 17.1.3. [INFO] [GL]: Using resolution 1920x1080 [INFO] [GL]: Default shader backend found: glsl. [INFO] [Shader driver]: Using GLSL shader backend. [INFO] [GLSL]: Checking GLSL shader support … [WARN] [GL]: Stock GLSL shaders will be used. [INFO] [GLSL]: Found GLSL vertex shader. [INFO] [GLSL]: Found GLSL fragment shader. [INFO] [GLSL]: Linking GLSL program. [INFO] [GLSL]: Found GLSL vertex shader. [INFO] [GLSL]: Found GLSL fragment shader. [INFO] [GLSL]: Linking GLSL program. [INFO] [GLSL]: Found GLSL vertex shader. [INFO] [GLSL]: Found GLSL fragment shader. [INFO] [GLSL]: Linking GLSL program. [INFO] Setting up menu pipeline shaders for XMB … [INFO] [GLSL]: Compiling ribbon shader… [INFO] [GLSL]: Found GLSL vertex shader. [INFO] [GLSL]: Found GLSL fragment shader. [INFO] [GLSL]: Linking GLSL program. [INFO] [GLSL]: Compiling simple ribbon shader… [INFO] [GLSL]: Found GLSL vertex shader. [INFO] [GLSL]: Found GLSL fragment shader. [INFO] [GLSL]: Linking GLSL program. [INFO] [GLSL]: Compiling snow shader… [INFO] [GLSL]: Found GLSL vertex shader. [INFO] [GLSL]: Found GLSL fragment shader. [INFO] [GLSL]: Linking GLSL program. [INFO] [GLSL]: Compiling modern snow shader… [INFO] [GLSL]: Found GLSL vertex shader. [INFO] [GLSL]: Found GLSL fragment shader. [INFO] [GLSL]: Linking GLSL program. [INFO] [GLSL]: Compiling bokeh shader… [INFO] [GLSL]: Found GLSL vertex shader. [INFO] [GLSL]: Found GLSL fragment shader. [INFO] [GLSL]: Linking GLSL program. [INFO] [GLSL]: Compiling snowflake shader… [INFO] [GLSL]: Found GLSL vertex shader. [INFO] [GLSL]: Found GLSL fragment shader. [INFO] [GLSL]: Linking GLSL program. [INFO] Resetting shader to defaults … [INFO] [GL]: Using 4 textures. [INFO] [GL]: Loaded 1 program(s). [INFO] [GL]: Using GL_RGB565 for texture uploads. [INFO] [Font]: Using font rendering backend: freetype. [INFO] [Video]: Graphics driver did not initialize an input driver. Attempting to pick a suitable driver. [WARN] [udev]: Couldn’t open any keyboard, mouse or touchpad. Are permissions set correctly for /dev/input/event*? [INFO] [udev]: Plugged pad: ShanWan PS3/USB Corded Gamepad (9571:1397) on port #0. [INFO] [udev]: Pad #0 (/dev/input/event2) supports 0 force feedback effects. [INFO] [Autoconf]: 260 profiles found. [INFO] [Joypad]: Found joypad driver: “udev”. [INFO] [Video]: Found display server: null [INFO] Found shader “/tmp/shaders/bilinear.glslp” [INFO] Found shader “/tmp/shaders/nearest.glslp” [INFO] Found shader “/tmp/shaders/slang-conversion-template.glsl” [INFO] Found shader “/tmp/shaders/stock.glsl” ALSA lib /home/kivutar/Lakka-LibreELEC/build.Lakka-Generic.x86_64/alsa-lib-1.1.4.1/src/pcm/pcm_dmix.c:1099:(snd_pcm_dmix_open) unable to open slave [ERROR] ALSA: Failed to initialize… [ERROR] Failed to initialize audio driver. Will continue without audio. [INFO] [Menu]: Found menu display driver: “gl”. [INFO] [Autoconf]: no profiles found for ShanWan PS3/USB Corded Gamepad (9571/1397). [INFO] [Font]: Using font rendering backend: freetype. [INFO] [Font]: Using font rendering backend: freetype. [INFO] [LED]: LED driver = ‘null’ 0x7eb180 [INFO] [MIDI]: Initializing … ALSA lib /home/kivutar/Lakka-LibreELEC/build.Lakka-Generic.x86_64/alsa-lib-1.1.4.1/src/seq/seq_hw.c:466:(snd_seq_hw_open) open /dev/snd/seq failed: No such file or directory [ERROR] [MIDI]: snd_seq_open failed with error -2. [ERROR] [MIDI]: Initialization failed (list of input devices unavailable). [INFO] SRAM will not be saved. [INFO] Loading history file: [/storage/.config/retroarch/content_history.lpl]. [INFO] Loading history file: [/storage/.config/retroarch/content_favorites.lpl]. [INFO] Loading history file: [/storage/.config/retroarch/content_music_history.lpl]. [INFO] Loading history file: [/storage/.config/retroarch/content_video_history.lpl]. [INFO] Loading history file: [/storage/.config/retroarch/content_image_history.lpl]. [INFO] [Font]: Using font rendering backend: freetype. [INFO] [Font]: Using font rendering backend: freetype. [INFO] [KMS]: New FB: 1920x1080 (stride: 7680). [INFO] [KMS]: New FB: 1920x1080 (stride: 7680).

/flash$ lspci -nnk | grep -A 3 VGA 01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GK208 [GeForce GT 710B] [10de:128b] (rev a1) Subsystem: Micro-Star International Co., Ltd. [MSI] GK208 [GeForce GT 710B] [1462:8c93] Kernel driver in use: nouveau 01:00.1 Audio device [0403]: NVIDIA Corporation GK208 HDMI/DP Audio Controller [10de:0e0f] (rev a1)

/flash$ aplay -L null Discard all samples (playback) or generate zero samples (capture) hdmi:CARD=NVidia,DEV=0 HDA NVidia, HDMI 0 HDMI Audio Output hdmi:CARD=NVidia,DEV=1 HDA NVidia, HDMI 1 HDMI Audio Output

/flash$ lsusb Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub Bus 007 Device 002: ID 2563:0575
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub


#2

With a Core 2 Duo? I don’t know…maybe try the experimental builds for that GT 710. http://www.lakka.tv/articles/2019/01/16/lakka-generic-nvidia-experimental-builds/


#3

Nice one @Shockwave i will give it a go!


#4

No joy sadly. I still see errors like previous…