No sound through HDMI on Intel Nuc

Hello everyone,

I’ve just installed Lakka on my Intel NUC5i3RYK and everything is fine so far, except I have no sound through my HDMI. I have a Yamaha A/V receiver.

Of course I’ve read the doc here: http://www.lakka.tv/doc/Audio-settings/#switching-audio-device-from-the-gui

By the way, I have not the same menu that the one we can see in the gif.

  • Under Drivers>audio i have “null, Alsa, Alsathread, Tinyalsa, oss”

So, i’m not sure it’s the right place, so If I go to AUDIO>OUTPUT>AUDIO (audio driver to use): i have the same “null, Alsa, Alsathread, Tinyalsa, oss”.

under, I have “DEVICE”: nothing is listed and if I enter the menu, the keyboard pop-up and i’m supposed to enter something i don’t know.

I’ve tried to list my hardware:

Lakka:~ #  aplay -L
null
    Discard all samples (playback) or generate zero samples (capture)
hdmi:CARD=HDMI,DEV=0
    HDA Intel HDMI, HDMI 0
    HDMI Audio Output
hdmi:CARD=HDMI,DEV=1
    HDA Intel HDMI, HDMI 1
    HDMI Audio Output
hdmi:CARD=HDMI,DEV=2
    HDA Intel HDMI, HDMI 2
    HDMI Audio Output
hdmi:CARD=HDMI,DEV=3
    HDA Intel HDMI, HDMI 3
    HDMI Audio Output
hdmi:CARD=HDMI,DEV=4
    HDA Intel HDMI, HDMI 4
    HDMI Audio Output
default:CARD=PCH
    HDA Intel PCH, ALC283 Analog
    Default Audio Device
sysdefault:CARD=PCH
    HDA Intel PCH, ALC283 Analog
    Default Audio Device
front:CARD=PCH,DEV=0
    HDA Intel PCH, ALC283 Analog
    Front speakers
surround21:CARD=PCH,DEV=0
    HDA Intel PCH, ALC283 Analog
    2.1 Surround output to Front and Subwoofer speakers
surround40:CARD=PCH,DEV=0
    HDA Intel PCH, ALC283 Analog
    4.0 Surround output to Front and Rear speakers
surround41:CARD=PCH,DEV=0
    HDA Intel PCH, ALC283 Analog
    4.1 Surround output to Front, Rear and Subwoofer speakers
surround50:CARD=PCH,DEV=0
    HDA Intel PCH, ALC283 Analog
    5.0 Surround output to Front, Center and Rear speakers
surround51:CARD=PCH,DEV=0
    HDA Intel PCH, ALC283 Analog
    5.1 Surround output to Front, Center, Rear and Subwoofer speakers
surround71:CARD=PCH,DEV=0
    HDA Intel PCH, ALC283 Analog
    7.1 Surround output to Front, Center, Side, Rear and Woofer speakers

I’m sorry to bother you, cause i’ve seen many people were asking for some help with this HDMI issue (or not). But many thread was around 2016-2017, things have change, perhaps since these days.

Thanks for your help.

Hello, sorry to bother you again, but can someone help me with my issue? I don’t know what to do right now… :frowning:

Hi,

First of all, try to make a test with nightly build if it is not already the case.

Then you should be able to see some audio device pressing right of left key. Each time you choose an audio device, you need to stop the core and relaunch it. You should try one by one the hdmi ones.

If it is still not working please provide some Lakka system log and dmesg.

Actually @gouchi it’s a bit more complicated than that, too.

He’ll have to try each entry in that aplay -L listing when he changed it in the Output setting by typing it in like sysdefault:CARD=PCH for the the default audio device, front:CARD:PCH,DEV=0 for his front speakers, etc. under Settings -> Audio -> Output -> Device.

He’ll have to try each entry in that aplay -L listing when he changed it in the Output setting by typing it

You should not need to type, just press left or right and it will display audio device.

I’m sorry, but I don’ understand. I know you’re a developper so you know Lakka better than anyone here. But i’m lost. :frowning: Like @Shockwave said, it’s written in the wiki we need to do a SSH connexion then do the aplay - L tricks in order to see the various cards we have on our system.

In your previous answer, you seems to say that we just need to press right or left in to test it.

Then you should be able to see some audio device pressing right of left key. Each time you choose an audio device, you need to stop the core and relaunch it. You should try one by one the hdmi ones.

Can you tell me where to do that please? In which menu/sub menu?

@gouchi he means here @Mydriaze: http://www.lakka.tv/doc/Audio-settings/

Thanks a lot, but i haven’t this sub-menu: please check my screenshot above at the beginning of this thread. By the way, I appreciate the fact that you try to help me.

You said in your first post

Go to Settings tab > Audio > Output > Device then you should be able to just press left or right and it will display audio device. If not there is an issue. If it is the case, please try to provide some logs.

Thank you.

I’ve run into this problem too (using the 12-21-2020 nightly). I can play test sounds successfully using speaker-test, but I also have to pass in -c 2 and a buffer size (-b 1000000 worked), otherwise I’d get “Setting of hwparams failed: Cannot allocate memory”

I had the same issue with a HP thin client, it had an internal speaker and all audio was coming out of that, I tried everything I could find on Google to no avail, you cant use left and right to change audio devices in the menu (Possibly not available in the stable release on the website) So, I SSH in to the box, do the aplay thing to list all interfaces, then just use copy and paste and paste each one in to the relevant place in the config file, until one works as you would expect, worked perfect here.

Thanks for your help. It works now with the latest nightly build. Weird.