Overlay + Mouse Pointer


With the use of overlay, the mouse pointer doesn’t stay hide.

I didn’t find a solution. Is there?



I think the solution is currently to hit F11 on your keyboard.


Is there any way that is automatic?



You might try some of the other input drivers. I think at least some of them do a better job of hiding after some amount of time…?


Nothing… Why it happen? It’s a bug?


Not exactly. The overlays are intended for control, which means using the mouse on PC. The feature wasn’t designed around the cosmetic/border thing, though it obviously works pretty well for that.

You might try this program, NoMousy:


Thanks for your tip, @hunterk!

LaunchBox (frontend) + NoMousy

  1. Download nomousy.exe and place it on LaunchBox folder.
  2. Open LaunchBox, menu Tools > Manage Emulators…
  3. Edit Retroarch.
  4. Go to AutoHotkey Script tab and paste this script:
Run, ..\LaunchBox\nomousy.exe /hide



Run, ..\LaunchBox\nomousy.exe

Process, Close, {{{StartupEXE}}}


It works perfectly, BUT the emulator has to be closed with ESC key to bring back the mouse pointer.

Unfortunately, only in the paid version is possible to associate the ESC key with the joystick buttons.

If someone knows how modify the script to run the nomousy.exe after Retroarch be closed, please, tell me.


If you don’t want to use launchbox, I would assume you could use a bat file to run the script, launch retroarch, and then disable the script when retroarch closes.


But how is the script to disable nomousy when Retroarch closes?



Dunno, I don’t use autohotkey, since I don’t use Windows (often).


@hunterk, I have now noticed that temporary files are not deleted by Retroarch if you use autohotkey.



That usually means it’s not actually quitting properly and is instead getting killed by another process.



Process, Close, {{{StartupEXE}}}

Has to be replaced by:

WinClose, ahk_class RetroArch

The corrected script:

Run, ..\LaunchBox\nomousy.exe /hide



Run, ..\LaunchBox\nomousy.exe

WinClose, ahk_class RetroArch




The code WinClose, ahk_class RetroArch is no longer closes the RetroArch.

Any idea?



Just a thought - this topic seems to come up very often. I would guess that the vast bulk of users use overlays for borders than for control (not that overlay control is not very useful, of course). If there is no desire to add an option in the GUI to hide the pointer, perhaps Retroarch can simply remember the last state of the pointer (hidden/or not) on restart like it does with other things like muted volume.

This setup could probably satisfy all users with minimal changes. This would be more convenient than manually pressing F11 every single time. It would also be for simpler and more elegant than having to run an additional application and scripts just to remove the annoyance of the pointer for people using standard controls.


I use an ahk so that when launching RA it moves the mouse pointer to the coordinates x=0 y=0 so it gets “hidden”. This also helps in not needing to make the cursor reappear afterwards if needed.


Poderia postar o script que você usa?



Hey! Im not at home right now, but try with this (change the numbers to match your monitors resolution):

MouseMove, 1920, 1080

I will check it in a while to see if that is what I used or was something different.


O mouse se move para a posição correta, porém, quando o RetroArch abre, o mouse fica centralizado.



How are you using it? Where are you writing it Nd how are you launching it + RA?