Overlays does not match with game?

I downloaded a collection of overlays from github today, to use with some arcade games. For some reason, the overlays cut part of the image in-game, doesn’t matter if i change the aspect ratio to 4:3. While using the aspect ratio provided by the core (in this case, FBA CPS2), it looks like this:

I am doing something wrong?

Try to apply a shader that provides de curvature of the monitor and it will fit the image.

quite a few overlays require a specific custom aspect ratio. I think some of them will tell you what they need in the text files, others will just require trial-and-error to configure your screen to match.

Understood. I though using either the core provide aspect ratio, or 4:3 option was enough

@Diego i was using crt-geom.cg in that screenshot!

1 Like

can you give an example of an overlay? do they come with .cfg files for each game? because retroarch changed the aspect ratio option numbers last year, which means that any pre-existing config files which attempt to apply ‘core aspect ratio’ will be broken, for example.

see https://github.com/libretro/RetroArch/issues/7536

This is interesting. I downloaded them from here: Over 1000 Arcade Overlays

They do come with a .cfg, yes, plus a .png, which in this case are the borders. I tried 4:3 and 16:9 and the default core aspect ratio as well, but still they don’t quite match with neither MAME nor FBA

hmm, it’s difficult to say. for example, the screenshot of SF2 on the link:

image

the actual screen area there is not in 4:3 (closer to 16:9), but SF2 IS a 4:3 game, so it looks like the author of the overlays has used integer scaling rather than the authentic aspect ratio, would explain why the SF2 looks wrong, since these games have a non-4:3 resolution (384×224), which is squished when being output to a 4:3 CRT (or when using 4:3/core aspect ratio settings in retroarch)

that said, at a glance it looks like the overlay opening for your CPS2 game example looks about 4:3 to me, but clearly the game image is closer to wide screen. i would be curious as to your retroarch.cfg settings in that example. if you use 4:3/core aspect ratio i would expect it to look right.

but in any case, i don’t think these overlay files are going to give predictable results looking at these two examples of games that should be 4:3.

I was doing this myself (and with Marvel Vs. Capcom, too) and you have to create a game-specific .cfg in your Retroarch config file with custom viewports. Here’s mine (using MAME core) (in \RetroArch\config\MAME\mvsc.cfg):

My personal overlay setting

input_overlay = ":\overlays\borders\mvsc\mvsc.cfg"
input_overlay_enable = "true"
input_overlay_opacity = "1.000000"
input_overlay_scale = "1.000000"

sets aspect ratio from default 22 (core-provided) to 23 (custom) and sets scale to be 1-pixel-specific

aspect_ratio_index = "23"
video_scale_integer = "false"

sets the width, height and x/y location of the screen. (x & y = position of top left corner of the game viewport)

custom_viewport_width = "1200"
custom_viewport_height = "900"
custom_viewport_x = "361"
custom_viewport_y = "95"

^those x & y positions worked for a 1920×1080 resolution using that exact overlay and using crt-geom shader (with the parameters tweaked slightly to make the curvature line up beautifully).

You (and others) might encounter the same problem I did, in that no matter how many times you set this as a game override (to override Retroarch’s default retroarch.cfg) it would revert back to the default config, and screw up the screen positioning. In which case, change Settings ► Configurations ► Save configuration on exit to “off” and remove a few lines from retroarch.cfg (be careful this might wreck your other settings and games, but I removed the following lines to stop Retroarch overriding its own overridings…)

aspect_ratio_index
video_scale_integer
video_aspect_ratio
video_scale
custom_viewport_width
custom_viewport_height
custom_viewport_x
custom_viewport_y

I just keep all of those in game-specific override .cfg’s (mainly MAME cabinet games) within \RetroArch\config\ [emulator] \ [game].cfg)

2 Likes

My bezel. Yes that’s pretty cool.

2 Likes

You’re always doing the best works. Thank you very much!

1 Like

Thank you. I appreciate that.