PAL NES ROMS play too fast in Nestopia


#1

Hello everybody

First of all, i must say that i’am french and my english is,quite poor, so i’ll make my best to be understood.

I’am running LAKKA on a Raspberry Pi3. It works fine, but there is something that annoys me.

When i load a nes rom from the nes playlist, no problem if it’s an US rom, but if it’s an european Rom (PAL-50hz), the game plays in 60hz, so the music and gameplay is too fast ! Seems like Mario had took ecstasy.

I’ve found out that if i go in the core options, in Nestopia, and change “favored system” by “Pal” instead of “Auto” while i’am running a pal game, everything is ok and the game runs at the good speed, the fps indicator turned on showing 50 fps instead of 60hz.

The matter is that if i then run a US Rom (NTSC - 60hz), leaving “pal” as “favored system”, then the game is too slow, because it’s playing at the wrong speed of 50hz. So i go back in the “favored system” tab and change “pal” by “auto”, and it’s ok for US roms…

I use NO-INTRO nes roms. I tried with the same rom on Nestopia on my windows laptop, and the “auto” option in “favored system” works fine… But it seems that in LAKKA Nestopia doesn’t take care of that option, running all roms, PAL or NTSC, at the default mode of 60hz.

It’s ok for me to change the option “favored system” by “Pal” or “Auto” depending the rom i’am playing, but it should be very cool that the “auto” option would work fine…

Notice that i’ve absolutely no problem with others systems i use in Lakka : SNES, GENESIS, master system, Game boy etc are ok, switching from 50 to 60hz depending of the version of the rom i’am playing… Was a litlle bit suprised to play alex kid so fast, but discovered that it was the correct speed, instead of 50hz gameplay of my french kid memories :slight_smile:

And also i tried to put the file “NstDatabase.xml” in the “system” share through Samba, did not change nothing…

thanks in advance for your help !


#2

d’oh, this was going to be my suggestion. Something must not be getting detected properly. I’ll try it on my own system when I get home.

In the meantime, does FCEUmm treat you any better?


#3

im not sure if nestopia supports matching region by filename. suppose to be anything that has (PAL), (EU) for example in the filename run the rom in PAL mode (at least that how other nes matches region since there is no identifier that can be used in header for this for ines 1.0)


#4

“Auto” is also being fed in by your monitor’s refresh rate…check the video settings (Settings -> Video -> Refresh Rate).


#5

Hello Hunterk

yes i’am interested by your feedback about NstDatabase.xml.

Then, about FCEUm, i’ve test to put it by default in the playlist core option, but the game still load with Nestopia. Si i load the core FCEUm and then load the game with it : it loads with FCEum but still in NTSC 60HZ mode… So it’s not better.


#6

Hello Wertz

Also tried this : the Rom is named “super mario bros (E) (REVA)” something like that, and Lakka displays it as “super mario bros (europe) (REVA)”. I tried to rename it by “super mario bros (U) (REVA)”, but after a re-scan, Lakka still displays it as “super mario bros (europe) (REVA)”, and it’s not better. Notice that i tried with another ROM version, which is a world version (W) and that’s ok, the speed is good, but it’s because it’s a 60HZ rom (FPS indicator displays 60FPS while playing).


#7

Hello Shockwave.

Already tried to disable the vsync option but not better…


#8

Hello!

I’ve tried all NES cores to get the best result, but none could help me. The only thing I didn’t was try to use the same ROM but in NTSC version (like your SMB as you mentioned).

Today I found a new solution: convert PAL to NTSC. The last answer suggest that in this link https://www.reddit.com/r/miniSNESmods/comments/8yf9nn/how_do_you_make_retroarch_load_up_specific_games/

I apologize for my poor English skills.


#9
  • nestopia uses NstDatabase.xml to detect timing for pal or ntsc games using crc to match. if these are rom hacks or patched files its possible it wont match crc on database hence it will run in ntsc by default
  • fceumm checks filename, e.g. filenames with (EU), (E), (pal) to name a few, will run on PAL timings.

see core options > Region and try to force game to PAL or NTSC and see if this helps.


#10

Yes, it helps, a bit. I tried a hacked ROM PAL to NTSC and was lightly most accurate for video and audio synchronization (animation was more fluid and audio has no slow down).

Sorry, but I prefer hacked ROMs.