PC Retroarch to CRT TV

Hello! I been trying for hours to successfully connect my PC to the CRT TV to play retroarch and this is the best i’ve done :

I have no clue what to do to fix this lol I’m using this converter

HDMI TO COMPONENT Untitled

Does anyone have any idea what might be the issue? Graphics card is a 1070 ti GTX

How are you creating your modelines?

I’m not really familiar with this process, but someone on reddit told me if i got this converter and set a custom resolution everything would be fine. The only thing i did was use a program called Custom Resolution Utility and i set a resolution of 240p there and in retroarch.

Could be an issue with pixel clocks. What’s the full resolution you’re giving it? I would recommend trying [email protected]

I was using 320x240 59.945hz lol imma try that one. Do i need to check any of the boxes on the sides? Also the timing Manual? or Automatic CRT?

EDIT : So i just tried that resolution and still the same issue. Not sure if it helps but the TV model is a 27inch FV310. When the tv goes crazy like that it does a lot of buzz noises

Unfortunately, I don’t know a whole lot about getting the right modelines in Windows. Hopefully someone who does can chime in.

So i tried to change the resolution in retroarch to 1920x240 and the image is not crazy anymore but looks messed up still lol as you can see :

eyyy, that’s good, though. You can go into settings > video and set a custom aspect ratio with integer scaling ON, then scale up the width until it fits (I think it’s like 5x or 6x).

So i set a custom resolution of 640x480 interlaced desktop and retroarch since this tv is only 480i and the image is steady but when i go into game it flickers like crazy…

Yeah, I’d stay away from interlaced resolutions if I were you. “240p” isn’t really progressive, it just doesn’t switch to the other set of lines/fields each frame (Nintendo’s name “double-strike” is a bit more descriptive), so it’s still compatible with 480i displays.

You’re not going to believe me at first, but it’s probably your adapter. I bought the same one a while ago, based specifically on people telling me it would work with RetroArch. Here’s my thread on it from a while back.

I’ve spent a -stupid- amount of time over the last few years trying different adapter solutions to get my Windows PCs to work with both a 31kzh CRT and a 15khz CRT using both CRU and CRT EmuDriver.

I’d have to check, but I’m not sure linuxbot has an HDMI to Component adapter. I ‘do’ have an HDMI to VGA adapter though, and I’ve been wanting to try connecting my other PC to my CRT, so I’ll try that daisy chain with CRU and report back as well.

Also, I can’t recommend using super resolutions enough. I’ve never, ever, gotten full native resolutions to work. Which there are some benefits to using anyway, so you’re better off in the end IMO. I’d set CRU to 1920x240 @ 60hz, Automatic CRT Standard.

1 Like

The thing is, whenever i set the resolution 1920x240 in CRU the tv goes crazy and i cant even have a steady image it only works with a 480i res which is horrible lol what resolution should i set to retroarch? Also do i check CRTswitchres?

As you can see in this image https://ibb.co/y5hZWx0 the only way to get it to ‘work’ is by having a custom resolution in the desktop of 640x480 Interlaced and also in retroarch. It looks horrible and the image is shaky because of 480i i think.

What about the image in PC Retroarch to CRT TV? That looked good to me. did it freak out once you stretched the image to fit?

1 Like

Unless I’m mistaken, RetroArch’s natural resolution when SwitchRes is on is 320x240 (or 1920x240 for super).

So, I just tried to setup my modern PC (It’s running an AMD RX 590) with my ‘current’ adapter and It’s a no go. Because of course not lol I’m talking:

  • GPU > HDMI > VGA > Component
  • GPU > DVI > VGA > Component
  • GPU > DVI > HDMI > VGA > Component
  • Onboard > HDMI > VGA > Component
  • Onboard > DVI > VGA > Component
  • Onboard > DVI > HDMI > VGA > Component

(I know a lot of those seem redundant, but my DVI to VGA adapter is also a splitter, so it was worth a shot to do some of the extra tries) All of them, I made 0 progress with CRU. Which is greatly frustrating. CRU was like magic perfection with my 31Khz monitor on this PC.

I’ve been running a separate PC with an older GPU specifically for CRT EmuDriver. So I’m trying to re-wrap my head around this. As I’m thinking, I have yet to get my 15khz TV to connect to my modern GPU, only the 31khz.

I am gonna dig out my Porta adapter, since I still have it and play with it. Maybe I can at least replicate what you are seeing and go from there.

I feel like my larger post just now may have bumped Hunterk’s idea. I agree that little column pic looks like the screen is at 1920, but the aspect may not be set correctly in video scaling settings.

im going to try and replicate that lol because i don’t really remember how i did it lol Should i check CRTswitchres? and Integer Scale? Do i also have to set a resolution in nvidia control panel?

EDIT : Okay done, image is steady but squashed on the sides. How do i fix this?

I dug out that adapter and threw 1920x240 and 1920x480 (interlaced) in, set RA to 1920 in crt and booted up Sonic 2.

Perfection, right?

Then I tried the 480i… Now I remember my huge issue with this adapter.

It is struggling like crazy with interlacing…

For aspect ratio though, set it to either core provided or custom (1920x240) and try a 240p game. See what you get.

Really wanna see if I can fix this interlacing problem now though.

Go into Settings > Video > Scaling, and set the aspect ratio to core provided or custom 1920 (6x) for width. Make sure integer scaling is on too, or custom scaling will be a way more tedious task than it needs to be.

Yep my retroarch launches correct now but when i set the aspect ratio to 1920x240 it doesn’t fit but i think this time it has to do with the geometry of this tv, i have no idea how to fix it tho.