Pi4 Lakka HDMI-VGA resolution issues

When using an HDMI-VGA adapter and a resolution of 2048x240, Lakka forces output of a 320x240 image centered in a 1080p frame.

If I try manual setting the fullscreen resolution to 2048x240, I don’t get a usable signal for any display I connect to it.

Any suggestions?

How are you setting your res? What kind of device are you using?

I’m using a Raspberry Pi 4.

I was using the same settings as I previously had for the retrotink. In config.txt: hdmi_timings=2048 1 180 202 300 240 1 3 5 14 0 0 0 60 0 42954545 1

Then, when I start lakka, it doesn’t show up on my screen. If I take it and plug it into my projector, I get an 1080p input with a centered image.

I can get an image using this setup if I load retropie and go into retroach from there. However, emulationstation is huge pain in the ass, and I can’t get the audio working among other issues, and I would always prefer to use lakka.

Additionally, I can get an image this way if I use the VGA output of the GPIO, but I am trying to get away from that because of the horrendous dot-crawl on the Pi4 header output. The Raspberry pi developers say they can’t fix it because they made the GPIO pins too close together. (https://www.raspberrypi.org/forums/viewtopic.php?f=91&t=94424&start=175)

I’m hoping that I’m just doing something wrong, but I feel like I’ve tried everything I can think of. Can you tell me what you think I should be doing, settings-wise?


I just tried a normal 240p resolution and that won’t work either.

320 1 16 30 34 240 1 2 3 22 0 0 0 60 0 6400000 1

Hmm, yeah, that’s what I was going to suggest: hdmi_timings in the config.txt. That forum thread suggests that maybe some timing stuff is different for RPi4…? If so, I guess that could be throwing off the signal.

Possibly. The situation seems to be that it works via the GPIO output, but when hooked up to and HMDI connection, Lakka outputs the same 320x240 signal centered in a 1080p framebuffer. Lakka seems to know that it’s supposed to be 320x240 because those values are reflected in the “custom aspect ratio” as x1.

If the signal is A-okay for the GPIO, what’s making Lakka puke when I switch to a digital signal?

I’d rather not assume things, but without any further information, it’s looking like Lakka automatically defaults the HDMI to 1080p.

Lakka will just use whatever resolution. If you’re setting a custom aspect with width and height of 1x integer scale, it will indeed put it right in the middle of the screen without affecting the overall resolution, as you’ve seen. If it’s the middle of a 1080p canvas, then your hdmi_timing isn’t taking effect properly.

You can set a video_fullscreen_x/y value and it will try to use that, but only if the modeline already exists and is available.

Using hdmi_timing in the config.txt sidesteps all of the RetroArch configuration and just forces a res for RetroArch to fill.

How am I supposed to get the modeline to take effect? Do I need to declare some CVT mode prior to the hdmi_timings? That isn’t the case for Raspbian. When I set the config.txt in Rapsbian, I used the same settings I’m using for Lakka, but it works completely fine.