Please show off what crt shaders can do!


#201

That fixed it, thank you!


#202

I was wondering if we could get some moire mitigation added to your new crt shader?

I think Hunter has some code on his blog for what I’m talking about…

@TayTayo is that the default settings for crt-aperture?


#203

no is not defaut settings,here is my setting :wink:


#204

I’m going to try those settings out in a bit. Currently I’m kinda partial to zfast_crt+dotmask, and I’ve also be using crt-guest-dr-venom alot the past few days, separate of course.


#205

@hunterk Thank you for the slang version. This shader is great!

I might have gone a bit overboard with screenshots.


#206

@Arviel Excellent screenshots! I’m assuming all those captures are showcasing the new shader by @guest.r?

I would be really grateful if you could post your presets for 2D and 3D content.


#207

Is it just me or is the @guest.r CRT shader more taxing then crt-royale?

I only noticed when messing with PSX games at 4x internal res though… :sweat_smile:


#208

Wow, crt-guest-dr-venom is amazing ! Thanks for sharing !


#209

@shenglong Yup, using the slang version of the shader. All the settings are the default, with the exception of the handheld shader where i removed the curve. Also using integer scaling for all cores.


#210

Do you alter the custom resolution video settings per core for (proper?) interger scaling factors (1x,2x,3x,etc.)?


#211

I simply use interger scaling with whatever resolution is provided by the cores, which for my resolution (1600p), it will be either 6x or 7x scaling depending if it is 224p or 240p content.


#212

The moment I saw it, I knew that some of you were going to like that shader (I mean guest’s, and of course I too find it terrific).

@Arviel 1600p + integer + guest = match made in heaven. Only “problem” I see is that the scanlines disappear completely in very bright areas. They should be more faint maybe, but still visible. Look at Gimmick’s clouds for example. For reference:

@TayTayo - very nice, thanks for sharing your settings. I miss some sort of mask effect though. For me, that’s as important as the scanlines themselves!

@Syh - Most crt shaders are designed with 240p content in mind. Many of them (caligari, pi, lottes/fakelottes, hyllian 3D and others) produce good results at higher internal resolutions, so I’m still experimenting, but for the time being, to get that look I’m using reshade and its pretty good AdvandedCRT shader on top of RA’s own aa-shader-4.0-level2-pass2 + image adjustment. I explained this somewhere around this thread before, but basically, the good thing about reshade is that its output doesn’t depend on the emulator/core resolution. You configure it for your screen resolution and that’s it. I’m currently using that configuration for RA’s hi-res content and also on every standalone emulator that I still play with. Also I’m really happy about how smoothly the 2D elements from these 3D games scale up with this setup. Some more examples (look at Shenmue! :star_struck:)


#213

These are looking pretty good! I like how the scanlines (black lines) are fairly consistent and become gradually thicker over darker colors, as they would on a CRT, and the bright colors aren’t excessively bloomed. This is starting to look very close to an actual high-end CRT.

That mask is a bit PVM-like, though. I prefer the coarser masks, myself, since they’re more accurate at 1080p to what an actual CRT mask looks like. The most realistic mask at 1080p is the aperture grille from “dotmask.” I want to be able to see the individual red, blue and green phosphors when up close. The mask interacts with the scanlines in a way that further enhances the depth and dynamic range of the image, and the mask provides a certain texture that makes the image look soft without being blurry. That might be the only thing I would change. I might also reduce the bloom just a tad/increase the scanlines strength just a tad, and of course I don’t really care for curvature but the amount you have there doesn’t seem too excessive. It also seems like there are some scaling artifacts with the scanlines, which could be removed with integer scaling; it’s a trade-off because then you lose the perfect 4:3 AR.


#214

@Nesguy It has the dotmask masks in there, it just defaults to cgwg’s mask (i.e., 0 instead of 2). If you replace the blur_horiz and blur_vert passes with stock, it kills the bloom altogether, which you might like (it also roughly doubles the speed of the shader on my system, so anyone unable to get full speed might want to take a look). You can also increase the ‘scanline bright’ parameter to >=1.0 to get a slight separation between full-bright/white scanlines.


#215

This does indeed look a lot better to me and closer to the look I’m going for (which, if I haven’t already made it obvious enough, is an RGB CRT and not the low-quality TVs we grew up with).

It’s still a bit too slow to run full speed on the Intel NUC I’m using as an emulation box. I’d like to see a trimmed down version that just does scanlines, mask, scaling, color/gamma/white point adjustments, and sharpness/blur adjustments. I may attempt it, but I still don’t really understand multipass shaders using different scales :stuck_out_tongue:


#216

Try replacing the first afterglow pass with stock, so all you have are the d65-50 pass, avg-lum and the actual crt pass with a bunch of stocks in between. That’ll be about as fast as it’ll go.


#217

Still a bit too slow, oh well. I like the sharpness and white point adjustments in this shader.


#218

I experienced the same problem as Arviel (Sapphire Radeon HD 6870). The shader downloaded directly from RetroArch needs to be fixed…

I tried this link and the shader worked correctly:

http://eab.abime.net/showpost.php?p=1295915&postcount=184

Great for Arcade games. Is the shader based on Arcade monitor?

Thanks.


#219

@guest.r

Why does the shader cut the image a lot?

crt-lottes-multipass

crt-guest-dr-venom


#220

That is due to the overscan option. Go into shader parameters and you should see it. Set to 0 to disable.