Problem with display on MXQ

Hello, I have this problem

I’m using the Lakka-S805.M201C.arm-2.1.img build and on internal I have Libreelec. I tried changing video_fullscreen_x and video_fullscreen_y to 1920x1080 in the config file but it doesn’t work. Also there seems to be a refresh rate problem that’s not visible in the picture. Any suggestions? Thanks

log file

That typically means there monitor is receiving an incompatible signal, either resolution or sync. You can try modifying the config.txt file to use a different resolution, like 720p or 640x480, just to test.

tried with different resolutions and setting video_vsync to false but no luck

Oh whoops, the config.txt thing only works for RPi, which I thought you were using. My mistake.

Since you seem to already know how to edit the retroarch.cfg file, you can try setting your menu_driver to RGUI and see if that makes any difference.

I changed it to RGUI and it improved a bit. The refresh rate problem is not so annoying and I’m now able to change aspect ratios to something more appropriate but I still have multiple smaller screens. I’ll try different settings combinations.

I don’t know well those devices but it is maybe related to Wetek Play issue.

I created the autostart.sh file as suggested in this comment and it work flawlessly.

Thank you so much for your help! :slightly_smiling_face:

Nice glad it worked !

1 Like

I have an HD18Q (marked MXQ on top but the PCB is marked HD18Q). Both the MXQ build and HD18Q build result in the same problem OP had. I tried the autostart.sh fix mentioned above, however it didn’t quite fix up my device.

After playing with various settings, I found one that worked great:

echo 720p60hz > /sys/class/display/mode
fbset -fb /dev/fb0 -g 1280 720 1280 1440 32

The HD18Q device I have also doesn’t like running in 1080P mode while Android is running, it also has major issues. Must be something to do with the video chip on it not liking 1080P. When I set it to 720P it works fantastic.

Cheers! :slight_smile:

I realize this is a bit old now but I had the same issue with the blinky quad screen. I am running from an SD card only. My resolution was to reflash the SD card with the image and do the first boot on another HDMI TV set. It booted to 1080p and has been fine since on both TVs.

Please Help. I have the same problem . How to make this file and where to load it?

create the autostart.sh file in /storage/.config/

nano .config/autostart.sh

add this to the file

echo 1080p60hz > /sys/class/display/mode

fbset -fb /dev/fb0 -g 1920 1080  1920  2160 32

restart

2 Likes