Problems with Lakka Installation

I have been trying to get Lakka on a HP T610 thin client, but after entering the installer command, it asks if I would like to proceed with the installation, and gives me a Y/N prompt, at which point it seems as though it no longer recognizes my keyboard. I have also tried to use a wired xbox 360 controller, which also didn’t work. Anybody know what I’m doing wrong? Thanks in advance.

It’s been a while since I’ve interacted with the Lakka installer, but is it possible that it’s still functioning, just without any visible cues? That is, have you waited for a few mins to see if it does anything after that?

So… this is embarrassing. Turns out there was something wrong with the USB drive i had the image on. Put it on a different one and everything went smoothly XD

Thank you for the suggestion though!!

1 Like

No worries, I’m glad you got it going. Sorry I couldn’t be more helpful.

1 Like

As I cannot create a new topic yet I will post it here. I tried to install lakka on a microSD to run on my odroid-c1 and every time I have installed it after I tried to boot the system I got the message:

xx Error in mount_storage: mount_common: Could not mount /dev/mmcblk0p2 xxx
## Starting debbugin shell... type exit to quit ###
h: can't access tty: job control turned off 

I have two microSD cards, one with 8GB and another with 4GB, and I could install and get it working but just the system, if I copy any rom to the microSD card partition it stop working and give this error with the mmcblk0p2

I could install an Android from the hardkernel (odroid manufacturer) wiki and it’s working fine.

Part of it could be a corrupted img file. In my experience I had a iso program corrupt the file upon writing and downloaded iso go corrupted possibly during the download process. Have you tried Belena Etcher and see if that gives better results. Did you use a stable build or a nightly build of lakka?

Thanks for the answer @Joystick2600.

I’m always using balenaEtcher. I dont’t think it could be a corrupted image, I will check if there’s a MD5 or something to test the downloaded file. I’m using the stable release. I will check if there’s a nightly build for the Odroid-C1 and test it too.

I’m afraid that it could be caused by my card reader. I have an old usb card reader and my laptop has a SD card reader but it’s does not detect my SD cards correctly.

This micro sd card reader from Kingston is kinda nifty. It has USB C on one side and USB A on the other.

This can happen if the kernel does not fully support the filesystem of the storage partition. Could you try the following: Insert the SD card to another linux system, then issue the following command:

tune2fs -O^metadata_csum /dev/sdX2

With /dev/sdx2 being the second partition on your SD card. Then remove the SD card and try to boot up Lakka again.

Should it works if I try to write the SD card using a Windows 10?

No, this would not help.

tune2fs -O^metadata_csum /dev/sdc2
zsh: no matches found: -O^metadata_csum

Escape the caret character for zsh:

tune2fs -O\^metadata_csum /dev/sdc2

Or try switching your shell to bash first: Execute /bin/bash on the command line, then type the command again.

I did a workaround. As I said, sometimes the install process worked, yesterday I could get it to install one more time and instead of copy the games to the same microSD card I copied the games to an usbkey and plugged it to one USB port of odroid-c1 and could play the game. I think I will stay with it a solution.

I ordered a new microSD card reader but I’m still not received it yet, maybe I give another try after it arrives.

Thanks for all the help @Joystick2600 and @mh287.

@ramonoak I personally like using a linux distro such as Elementary OS or Linux Mint on my pc when transferring roms, I do so without needing to do samba or ssh. Even manual updates I do it via Desktop file manager. Though for some folders I have to open them as root to gain access. I usually organize my roms in folders when it comes to unl/rom hacks/english translated games/ formats ie, gdi, cdi for dreamacast.

So far a few tutorial videos on Lakka OS. You can make your own custom thumbnails too :3