ps4 controller doesnt work along ps3 controller

Hello -For starters im new to the linux commands and stuff, and i tried my best reading from lakka website and the forums, but no luck. -My problem briefly is that when i use ps3 controller with lakka, everything works perfectly, but as soon i plug in the ps4 controller, the buttons on both controllers (even if a keyboard is attached) get mixed up, and up and down skips from 3 to 5 lines at random when i try to move around , and as soon i remove the ps4 controller, everything work fine again. -This problem was here from lakka 2.0 and still here on lakka 2.1

  • i will explain all what i did and what happen to me to this point 1) Installation of lakka A) I download the lakka image from the website, and use Etcher to write the image into an sd card B) After 1st setup is finished and rebooted, lakka it working with this problem

2) what did i try to do? A) I tried to use the input “bind all” to config the ps4 controller buttons layout, but when the controller is attached i cant press anything, so i increased the 5 sec time to 15 sec , so i can use another controller or keyboard to navigate to the command and press it, while the 15 sec ticking , i remove the current controller and insert the ps4 controller and start mapping the buttons , Now the good thing is the ps4 controller work find with no problem , but no wait! the ps3 controller start to do the same thing the ps4 controller used to do. i tried to do it with and without save config. same results

B) take the premade config that is made by others and put it into the joypad file inside lakka, nothing work, and it feel like i did nothing. i saved the ps4 config and saved it in my pc, done the same for the ps3 config as well, then i returned them to the same file they got originally saved in, Results :- ps3 controller doesnt work

How i solved it for version 2.0 ? -Actually i didnt , i left the kids with two ps3 controller to play on the device and someday i attached ps4 controller forgetting the problem, then suddenly i realized that im using ps4 controller along ps3 controller!

  • Nintendo 64 Games also worked better than before, no glitches and little bit higher fps, i always used mupen64 and never used parallel

But with this, another problem had appeared :- 50% of MSX games doesnt work with a controller and im required to attach a keyboard and change the controller to keyboard so i can play them

hope this info can help as well I installed a fresh lakka install and copied the files trying to find where is the file that made the controllers work, with each files copy i do system restart and check the controllers , then i found that one of the files in the lakka partition, (the one that can be accessed by windows by mounting sd card) did the trick, but im not sure which file exactly. “if needed i can do it until i find the specific file”

Notes -for every solution i try, i always test it before and after system restart, and i check it the files are copied correctly.

Sorry for the long post but i tried to mention everything i know, i know the solution might be so silly, but as i mentioned im new to this, so dont be harsh on me :slight_smile:

1 Like

Thank you for the detailed report.

Is it possible to try this operation ? To check if resetting ps4 autoconfig profiles make it works better.

Thank you.

I tried that method and it didnt work, either i did somthing wrong, or it didnt work for me

  • i couldnt create the cfg file since i cant press anything while the ps4 controller is attached so i lunched retroarch on pc and created the cfg file there and transfered it to lakka , then i copied the configs on the other thread you told me to, to the lakka cfg file while maintaining the vendor id and product id i got from retroarch as shown in the picture
  • i think that lakka dont read the files that i edit and save with notepad

BTW , the old lakka im using, the one that suddenly was able to run ps3 and ps4 controllers , dont have any config files

Hey I was having the same issue but Linux always shines though lol. Follow the instruction in the link this will guide you in adding the ps4 controller mac address as a trusted device so each time you power on lakka it will connect each and every time.

1 Like

I forget to mention that i tried the manual button remap again, but as i mentioned earlier, when i remaps ps4 controller, the ps3 controller stop working.

This guide explain how to connect a controller wirelessly, my problem is that lakka auto config make the ps4 controler repeat the buttons pressed, similar to the issue mentioned in the other topic

@Koolyap Did you check in /tmp/joypads/udev ?

can you check in /tmp/joypads/udev to rename dualschock 4 cfg file and try to rebind your DS4 ?