PSX not working on RPI4

So, I got Lakka working in my RPI4 4GB. It seems to run NES, ScummVM and Sega MD fine, but won’t even launch PSX games. I have copied working (checked) BIOS files to the System directory. Games are in both ISO and PBP formats.

What am I doing wrong?

which core are you using? Is your system running a 32-bit or 64-bit OS? If you post a log of you trying and failing to load a game, I can take a look.

PCSX ReARMed cannot run ISO files, please try the CUE/BIN format

The problem is I can’t find the option to download a custom/specific core on this RPI4 version of Lakka. It seems slightly different than the previous one I used, a Windows based one. The cores are already installed.

Yes, RPI4 is a 64 bit machine.

No the RPi4 software is entirely 32bit, apart from a few distros out there

Also you cannot download cores for Lakka, they are supposed to be all there from the start

Hm, I read it’s 64. Never mind, 32 then. Exactly, the cores are there, but not all of them. There’s only one available for PSX, and if it doesn’t work, I can’t substitute it.

And downloading a core from and putting it in /storage/cores/?

Isn’t this working anymore?

[EDIT] Was addressed to this:

The PCSX ReARMed core shipped with Lakka should work and you shouldn’t need another one, what is the exact issue you’re having?

Which folder should I loot for the cores to be compatible with RPI4?

As natinusala said the build-in PCSX ReARMed core should be sufficient.

ISO doesnt’work, but *.pbp should be ok. Better are redump verified bin/cue

For the RPi you need one of the arm cores, but i’m not sure which. Try both.

My problem is it doesn’t work as supposed.

PSX: failed to load content. Amiga: failed to load content. Arcade: failed to load content.

Plus, the weird design which doesn’t allow me to download desired cores myself, which I’m used to.

PCSX ReARMed on rpi4 running lakka is working over here, albeit with pathetic sub 30fps results.

Unfortunately I don’t remember what I did exactly to get everything working, but I did download a bunch of the bioses until i found I was on stable ground.

Lakka:~/system # pwd /storage/system Lakka:~/system # ls -lah psx total 3586 drwxr-xr-x 2 root root 1.0K Sep 27 02:55 . drwxrwxrwx 4 root root 1.0K Sep 26 18:44 … -rwxr–r-- 1 root root 512.0K Sep 24 01:04 SCPH1001.bin -rwxr–r-- 1 root root 512.0K Sep 26 18:34 SCPH5500.BIN -rwxr–r-- 1 root root 512.0K Sep 26 18:34 SCPH5502.BIN -rwxr–r-- 1 root root 512.0K Sep 26 18:17 SCPH7001.BIN -rwxr–r-- 1 root root 512.0K Sep 26 18:43 scph5500.bin -rwxr–r-- 1 root root 512.0K Sep 26 18:43 scph5501.bin -rwxr–r-- 1 root root 512.0K Sep 26 18:43 scph5502.bin Lakka:~/system #

So far, the only games I have are games I have discs for. So my results are:

NFL Blitz works great, runs at constant 30fps NFL Blitz 2001 runs almost as well, dips below 30 but still playable Syphon Filter 2 and 3 both are horrible at 15fps if not lower.

I can’t seem to break a 30fps cap either.

Funny thing is I have ALL the bios files. I have Retroarch installed on my PC, where I got everything to work. I took all the bios files and copied it to the correct folder on my Lakka SD card. And, well, it doesn’t work anymore.

The problem extends beyond PSX, however I’m yet to convert my iso’s to bin’s. (PBP’s don;t work). Lakka seems unable to open Amiga ADF’s and Arcade ZIP’s, which I could run on my old Pi Zero.

I’m not too sure what else to say on that. So far i’ve tested everything successfully and found other games to run at full speed so far. Haven’t tried any Amigas/Arcades yet, but PSX, NES, SNES, N64, Doom, and Quake all seem to be working for me. Have you tried a nightly build?

Most of my PS1 games work fine. I have to load them directly because Lakka can’t find them, maybe because they’re in .PBP format.


The scanner works only with bin/cue

Small correction: CHD also works with the scanner, so it should be the compressed format to use in this case.

1 Like