Raspberry Pi 3b, Stuttering Lakka with NES/SNES emu


So I want to update to the newest Lakka, but ever since a few versions ago, its performance is poor on my Raspberry Pi 3b and I’ve been waiting for a properly working update for over a year now.

Last night I tested FCEUmm, Nestopia and SNES9x (only the one without year) and they all stutter on basic settings without any shaders. Every few seconds a few frames will drop, as well as sound.

I own a Raspberry Pi 3b (non plus) What is happening? My older Lakka (that was the newest as of March 2017) performed without problems.



Try turning off your Hard GPU sync on your settings. That’s the first thing that pops to mind when I hear this problem.


Does the Hard GPU sync option even do anything on a Raspberry Pi? I heard that it doesn’t, so I never turn it on, and it was already off. Still, I tried turning it on just in case there would be a difference (better or worse) as well as trying different “sync frames” (0 - 3).

Same problems.

I tried other “Nightly releases” just in case, but the SNES9x always has an unfixable stutter. All default settings “out of the box” will give me stutters. It doesn’t feel like it is at fixed intervals, because it can happen at any time during games, even when the game is just displaying a mostly static screen with just music, then I notice pops and clicks in the music.

In my 2016/02 version of Lakka, that would only happen if I increased the frame delay to above 5. Here it happens anywhere.

Is anyone with the latest version of Lakka + RPi3b willing to share config files or settings with me?


Let me test, in the meantime, generate a log for the devs so they can check it (now I know why they say that all the time).


Loool. Thank you for your responses btw. I don’t know how to generate a log, but will be looking for how to do it. In case I don’t find it, how do I do that?

Edit: OK!! I’ve made a shocking discovery. I forgot one, but only ONE thing in my previous posts that I considered to be ok to ignore: the “Max Swapchain Images” value.

By default, it comes with a 3. However, in the old Lakka I used, I’d set this to 1 to reduce input lag as much as possible. Never would I consider anything higher (as each increasing number means 1 more frame of lag?) and setting it to 1 never gave me any problems on any cores with any games, so I never thought it would be a problem. But after the last post, I flashed a new install just to test one last time, and did not change this. No emulators stutter with it set to 3! :open_mouth: but that’s a problem, because it adds lag. Something must have been changed here between the one I use and last versions, because now setting it to 1 introduces crazy stuttering, although it does reduce lag like crazy too. I was happiest during the times it did not stutter, as the games would be nearly as responsive as the real games. I don’t like how it feels at 3. (Also, setting it to 2 still makes games stutter, 3 is the one that does not.)


Hello, I get a similar issue with Lakka 2.1 on my RPi3 B (non-plus).

I suppose it’s not performance-related (I see costant 60fps) but I notice some stuttering on “long” scrolling sprites, horizontal or vertical (i.e. Night Slashers attract mode / intro on FBA).

“Max Swapchain Images” is 2, but if I set a 3 value stuttering still occurs (but it seems somehow different in timing). If I set “Max Swapchain Images” again to 2 or 1, LAKKA crashes!

VSync is set to OFF and threaded video is ON, I wonder if monitor refresh value matters.

Thank you very much!


for me fixed like this that i edited SNES playlist in : \lakka\Playlists\Nintendo - Super Nintendo Entertainment System.lpl it’s pure txt file. i have just one game to snes for now and inside txt file have two lines to cores.

open file in windows like notepad++ or linux with using your used text editor like kate, leafpad or somethin else

file looks inside like this:{ “version”: “1.0”, “items”: [ { “path”: “/storage/roms/downloads/SNES/Star Ocean (Jap) [T+Eng 100% 1.0_DeJap].smc”, “label”: “Star Ocean (Japan) [T-En by DeJap v1.0]”, “core_path”: “/tmp/cores/snes9x2010_libretro.so”, “core_name”: “Nintendo - SNES / Famicom (Snes9x 2010)”, “crc32”: “6BA9E08D|crc”, “db_name”: “Nintendo - Super Nintendo Entertainment System.lpl” } ] }changed to: { “version”: “1.0”, “items”: [ { “path”: “/storage/roms/downloads/SNES/Star Ocean (Jap) [T+Eng 100% 1.0_DeJap].smc”, “label”: “Star Ocean (Japan) [T-En by DeJap v1.0]”, “core_path”: “/tmp/cores/snes9x2005_libretro.so”, “core_name”: “Nintendo - SNES / Famicom (Snes9x 2005)”, “crc32”: “6BA9E08D|crc”, “db_name”: “Nintendo - Super Nintendo Entertainment System.lpl” } ] } question is for now how to change whole system default overall any hasle?