Remove border from maximus-royale?


I have discovered that crt-maximus-royale is a great (best for me subjectively) shader for playing PlayStation games that use 3D character models on static 2D backgrounds (think Final Fantasy VII or other Square JRPGs). The only problem is that they come with a fake TV border/bezel that can’t be turned off:

I spent an evening trying to manually “hack” the shader files to get rid of it, but most of my attempts either did nothing or corrupted the visuals (anything from slightly different coloring to full black or garbled screens).

In the end I just edited the bezel .png file to be completely transparent, which did get rid of the bezel, but left black edges instead:

Is there a way to remove the bezel/border/edges, so that the image is stretched to the full size of the viewport, without any black borders?

1 Like

Hmm, I tried to take out the borders, but I don’t have the knowledge for that as I don’t think it’s just a matter of simply changing Shader Parameters. Since no one answered yet, I think it’s a safe assumption that it is stuck.

However, when playing 3d games with pre-rendered backgrounds, I’ve found GTU-V050 in the CRT folder to be excellent with those. Also, check out the NTSC folder, some good options in there. I’d presume you’ve already checked out both Cyberlab Drez options, and Sonkun’s NTSC2 presets as well; they work pretty well with those too.

GTU-V050 examples:

RetroArch Example - Imgsli

RetroArch Example - Imgsli

RetroArch Example - Imgsli


Also, Guest-Advanced-NTSC is a pretty good option too.

RetroArch Example - Imgsli

I’d love to know this too. Tried to tinker with it with no success.