[retroarch.cfg] How to disable Auto-Saving when shutting down Lakka?

Lakka Version: Generic.x86_64-3.6

I have already switched “Save Configuration on Quit” to “off” but Lakka keeps Auto-Saving the “retroarch.cfg” when using the “Shutdown” function.

This is very annoying. Is there anything I can do about it?

That should do it, but you could always ssh in and set the file to read-only.

So this is a bug? Setting the files to read-only seems not very practical.

I guess it could be a chicken/egg sort of issue where setting it to not save on exit doesn’t get saved on exit… Have you tried using main menu > configuration file > save current configuration?

Yes, I’ve done that. I also checked the retroarch.cfg file. The setting is saved and correct (config_save_on_exit = “false”).

Hmm, that’s very strange. In that case, setting it to read-only shouldn’t do anything either.

When using Reboot or Shutdown items, widget is shown on screen that config is being saved + command to save configuration is called. I guess this should be protected by some (pseudocode):

if (rarch_settings->auto_save_config) {
   /* code to show widget + save configuration that is currently in retroarch.c */

I will look into it deeper and prepare a patch.

Restart RetroArch honors this option.