Retroarch Citra Core

The citra core can not find the mii data, the folder with the files is already in the system folder. Would anyone know how to explain the correct procedure for citra core to identify the files? Or if someone can provide a link, with the files in the system folder already configured to download, I will be very grateful

1 Like

I keep hearing about ‘additional’ files for Citra, but I myself have failed to find what they are, where they go, and what they do. I too would love some information on the matter.

I had already put the citra user folder in the retroarch system folder and it had not worked, I tried it again and for some kind of magic, citra core began to recognize the mii data, but still continues with problems in the image of mario 3d land.

You should put the files here: C:/Users/[your-user-name]/AppData/Roaming/Citra/

or here: C:/Users/[your-user-name]/AppData/Roaming/Retroarch/user

EDIT Additional information regarding the files and how to dump them:

Why does the Citra core not support CXI files. I dumped my installed games, as the Citra Wiki describes here:

Is there no way to make it a relative path? I keep RA and all my roms on an external HDD that I take with me everywhere lol

I found the solution for my problem with CXI files.

I edited the file “citra_libretro.info” by adding the extension myself to


supported_extensions = "3ds|3dsx|cia|elf|cxi"


Now the Citro core sees the games and loads them. But when I close a game from the menu, Retroarch crashes (Windows x64).

I did as you said, but still with the same problem, he recognizes the file, but has a problem in the game, see the attached video. Would you know why this happened?

Mario 3D World

That video showed quite good why I don’t recommend using the Citra core yet, the same goes with Dolphin I’m afraid.

It’s too new to be even close to stable and it has to mature, heck even the standalone Citra has to mature as it too have it’s share of issues.

However if you guys are serious with 3DS emulation I highly recommend using the official Bleeding Edge builds of Citra instead, it’s the same as nightly builds, with additional features that are still waiting on review before making it into the official Citra.

I downloaded Citra Bleeding Edge and it’s working fine, thanks for the help.

Glad to hear it worked out for you!

EDIT Seems like they’re dropping Bleeding Edge builds:

Working on the crash.

Those are issues in nightly as well - bleeding edge/canary has a fix. I will be updating the core soon when these changes are merged.

Not currently. Waiting for a upstream fix to allow for abstract filesystems, so that we can use Libretro paths. For the time being though, no.

1 Like

Just wondering, did this fix ever occur?

No, though the core does not optionally provide options to save in LibRetro’s save location if available.

Has anyone found out where to put files from Citra into Retroarch so it recognizes Mii data? It doesn’t work in either the Roaming Citra folder nor in Retroarch’s system folder, or in Retroarch’s roaming folder, so I’m out of ideas :confused:

1 Like

Is there a way to use the stylus/touchscreen with the right analog stick in the actual citra emulator?

I’m still struggling with this. The font issue in SM3DLand is fixed, but half my games won’t start 'cause of a “Mii Data” error.

If you already have your Mii data ready & available (Config, Nand, SDMC, Sysdata) Place them inside the Citra folder thats located in… Retroarch/Saves/Citra/Place-Miidata-Here.

Took me awhile to figure out where to place this data. Doesn’t use the same location as the official Emu & really isnt stated anywhere that I could find here letting people know where to place this data. After days of searching, I stumbled onto a random Youtube video & someone in the comments where this data needs to be for use with Retroarch.

4 Likes

AHA!!! That must be it - I always set savefiles to my content directory instead of the RA directory (way easier for file management IMO) I had this same problem with MAME where it refused to look anywhere but the RA directory. I’ll probably have to do the same thing I did there and make a core override that points it to RA instead.

I’ll have to try this tonight when I’m home and report back.

OH MY GOD, you are a lifesaver! I spent hours trying to find out where to put those files without breaking it all, and you were the only one I could find who had the right answer. I already had Citra installed before I installed Retroarch, so I just copied and pasted all the folders and files from the Citra folder that was already installed and it worked perfectly! My save file even transferred over. Now I just have to figure out how to change the controls back to normal. Someone really needs to put this into the documentation for this. Thank you so much for your help!