RPG Maker error RPI 4

Raspberry Pi 4 B 4gb ver Lakka rpi4 nightly build

Some of the games I get errors. When trying to launch them there is no RPG Maker choice when trying to use the .exe extension of the game. They only launch with .ldb extensions and when they do they give a error. As for the RTP’s do I just throw the ones straight from RPG maker site unzipped into system/rtp/2000 and system/rtp/2003?

I have the system/rtp/2000/rpg2000_rtp_installer.exe for my RPGM 2000 games and as for 2003 its system/rtp/2000/rpg2003_rtp_installer.exe

I went back and even added the folder in its respective folder (RPG Maker 2003 RTP) in system/rtp/2003. Im not sure what Im doing wrong.

Games tried with errors, Lisa the First, One Shot, Yumme Nikki

With Yume Nikki it causes Retroarch to freeze, with the following message "Error: Invalid encoding: ibm-943_P15A-2003

EasyRPG Player will close now. Press Enter key to exit…"

I have no idea what that error means, but I just tried Yume Nikki and it worked for me.

If it helps, here are the steps that I followed: Download the game on Steam, copy the whole game folder to \Lakka\roms\yume, select “Load Content” in Lakka and then point it to the RPG_RT.ldb file.

A suggestion, do a clean re-download of the game, then don’t launch it on your download machine before copying it to Lakka to make sure the game files are unmodified.

Regarding .exe files, Lakka as a linux system cannot run them, they are Windows executables. They would also not be compatible with the CPU architecture of the Raspberry Pi.