RPI-4 to CRT issues

Having problems and I’ve looked over several forums but no luck.

I picked up a Sony KV-27FS120 for free from someone local wanting to get rid of it. It’s an awesome CRT so my plan was to get a RPi 4 and use a HD fury 3(hdmi to component) I have to transcode the signal to something the tv would display.

It’s a 480i consumer tv so I tried hdmi mode 6 first, which displays the initial Lakka icon fine but once Lakka loads the picture is horrible with scrolling lines, artifacts, etc. I tried setting a custom aspect ratio to 640x480, turning off v-sync, threaded video, internet scaling but nothing fixes or really changes the video.

I’m pretty sure the hd fury is working fine based on the fact the Lakka icon boot screen looks perfect. But doesn’t keep whatever resolution settings it’s using then once the Lakka menu loads? So it’s got to be something with the Lakka menu video settings?

At this point I really don’t care about true 240p etc. I would almost prefer 480i since I plan to use it primarily for n64/ps1/Dreamcast. I can probably use a scan line shader to get an acceptable 240p look.

I would try doing hdmi mode 2 and let the fury handle the interlacing.

Just as an FYI, you’re not going to be able to get a good 240p look at 480i, but that’s okay!

1 Like

IIRC if you use a scanlines shader at 480i you’ll have a horrible flickering. But I could be wrong.


You can use composite output - see https://lakka.tv/doc/Raspberry-Pi/#composite-output

For audio I think you have to use audio output device default:CARD=Headphones (set via Settings → Audio → Output Device)


Going composite is a last resort for me for a few different reasons. I’m going to try the suggestion hunter made above and I’ll report back.

No go. So far every mode I’ve tried results in the same visual artifact. However it seems the higher resolutions I try result in thinner horizontal lines moving towards the bottom right of the screen. Lower like 240p results in still awful, but I can make out a few icons or words. Probably artifact due to the screens refresh or something. Not sure.

I’ll add I wasn’t sure this would work as the HD fury 3 doesn’t convert anything. If I send it a 1080i, 720p, 480i signal to it, it just spits out the same through the component.

It is odd that using mode 6 (480i) makes the lakka boot icon with black screen look great, perfect even. This is the only mode that makes the lakka boot screen with the icon look good/normal. But as soon as it loads the menu it is doing something different in terms of display output that doesn’t work with the TV.

So… I’m thinking the display output in the pi’s config is correct, ergo the icon screen displaying correctly, but then lakka is changing something or not outputting the exact same as what’s in the pi’s config file?

If that’s the case, you could try setting video_fullscreen_x/y values in your retroarch.cfg and try to pin down a specific res. RetroArch doesn’t have any way to set interlacing on its own, though.