RPi4: Bluetooth controllers will not persist

I have a 8Bitdo SNES30 and whenever I restart my RPi4, it will not reconnect via Bluetooth unless I run all the commands again. What am I missing? I followed: https://www.lakka.tv/doc/8Bitdo-Wireless-Controller/

(controller not yet turned on)

systemctl status bluetooth

● bluetooth.service - Bluetooth service
   Loaded: loaded (/usr/lib/systemd/system/bluetooth.service; enabled; vendor preset: disabled)
   Active: active (running) since Tue 2020-03-10 01:47:34 UTC; 16s ago
 Main PID: 521 (bluetoothd)
   Status: "Running"
   CGroup: /system.slice/bluetooth.service
           └─521 /usr/lib/bluetooth/bluetoothd

Mar 10 01:47:34 Lakka systemd[1]: Started Bluetooth service.
Mar 10 01:47:34 Lakka bluetoothd[521]: Bluetooth daemon 5.47
Mar 10 01:47:34 Lakka bluetoothd[521]: Starting SDP server
Mar 10 01:47:34 Lakka bluetoothd[521]: kernel lacks bnep-protocol support
Mar 10 01:47:34 Lakka bluetoothd[521]: System does not support network plugin
Mar 10 01:47:34 Lakka bluetoothd[521]: Bluetooth management interface 1.14 initialized
Mar 10 01:47:34 Lakka bluetoothd[521]: Failed to set privacy: Rejected (0x0b)

^ The service is on as expected.

Lakka:~ # bluetoothctl
[NEW] Controller B8:27:EB:96:FA:66 %h [default]
[NEW] Device E4:17:D8:9E:6C:xx 8Bitdo SNES30 GamePad
[NEW] Device E4:17:D8:5A:63:xy 8Bitdo SNES30 GamePad
Agent registered

[bluetooth]# agent on
Agent is already registered
[bluetooth]# default-agent
Default agent request successful
[bluetooth]# power on
Changing power on succeeded
[bluetooth]# discoverable on
Changing discoverable on succeeded
[bluetooth]# pairable on
Changing pairable on succeeded
[bluetooth]# scan on
Discovery started
[CHG] Controller B8:27:EB:96:FA:66 Discovering: yes
[NEW] Device xx:35:0C:01:7F:6E N01F5

The guide says to turn it on via Mode 1, which is hold down Start. I turn the controller on that way.

[CHG] Device E4:17:D8:5A:63:xy RSSI: -58

[bluetooth]# connect E4:17:D8:5A:63:xy
Attempting to connect to E4:17:D8:5A:63:xy
[CHG] Device E4:17:D8:5A:63:xy Connected: yes
[CHG] Device E4:17:D8:5A:63:xy Paired: yes
Connection successful
[CHG] Device E4:17:D8:5A:63:xy ServicesResolved: yes

I then trust the device.

I reboot and the controller no longer reconnects via Bluetooth. I’ve tried pair in the command window too during these steps, but it continues to no longer be reconnected after a reboot.

I have also tried Pair then Trust, no luck.

What am I missing?