Run Philips CD-i games in Retroarch (mame_libretro) via RocketLauncher


#1

I’m not sure if it works with bin+cue, I tested with a CHD CD-i game.

You’ll need:

Retroarch 1.4.0 (or above) and the main MAME core (without year tags)

A CD-i game in CHD

cdimono1.7z or cdimono1.zip (proper for MESS, now MAME) this file should be inside the same folder where the CHDs are, no other location will make games load and RA will crash.

Maybe you’ll need to open a normal MAME game using retroarch first to change three options, they are:

Enable softlists (OFF)

Media type (cdrm)

Boot from CLI (ON)

Now load the game, it should run without problems.

In this game, the mouse sensitivity was too high and I had to configure all inputs in my gamepad inside MAME OSD config, it’s not TAB, in Retroarch it’s dash.

Even changing the options above, all other MAME systems should work without any problem.


Has anyone managed to run CHD Philips CD-i game under windows?
Mess - Mame setup for macintosh emulation
Core and Feature Requests
#2

My options setting are all off no boot to OSI. I use dummy files and all load perfect


#3

This is nice man, I think this way of Booting from CLI is easier, since there’s no need to create dummy files. But it’s good to know that you have it working in another way.


#4

I’m copying the text from the NEO GEO CD tutorial as it applies to this one as well.

I tried to run NEO GEO CD using the hash, dummy and naming the CHD according to the hash file naming, naming the roms folder to neocdz, Retroarch crashes, I’m not sure why it crashes since it works fine via RocketLauncher, so it’s definitely not a MAME driver problem.

It doesn’t mean this guide is not useful, I use RocketLauncher, Hyperspin as my frontend. RocketLauncher gives Retroarch instructions on what to run and how to run it, that’s where comes the Boot from CLI. Although Retroarch is crashing in the hash and dummy method (not covered in this tutorial), if you use a frontend that is managed by RocketLauncher, NEO GEO CD and other systems emulated by MAME will run fine.

I also updated the title stating it’s focused for RocketLauncher use.

When I manage to run these systems in the most common way (directly via Retroarch) I’ll make a guide explaining how, if no one else does before.

I’d like that someone that has this system working in the hash and dummy method, to confirm that it’s working on the latest stable Retroarch build and core, so I can figure out why it’s crashing.


#5

Do you have chds in there own folder? It should not crash on you that’s wired.

neocdz/neocdz/ Roms and chd folders/ BIOS

I like to run BIOS in both folders too and also extract them


#6

I’ve figured out later that I can have the CHDs any folder I want and also have any name I want for them, if I use RocketLauncher, if you launch games directly via Retroach, then you should put it inside the correct folder and follow the hash naming.


#7

Hi guys, first post here.

@aorin1, how is it going? I am coming from the hyperspin forum, hope you remember I was making questions about philips cdi and neo geo cd hehehe

Well, here I am and I had a couple of questions. First, I got all the chd roms for both system and had configured them as much as I can to your tutorials, but in the Philips-cdi when I run any game, it starts with a light blue screen and then it goes to the main menu system of the philips cd-i, where you have to press play, stop, etc and the logo of philips is there as well.

What may I have been missing? or is it the not all the games run properly?


#8

Hey, yeah I remember, it’s nice my guide helped you running these systems. The blue screen for CD-i is normal, I never had a CD-i, but I think (except for the light blue screen), when you insert a game you need to press play to start the game, maybe it’s how its bios work, not sure though, but it’s the same way it runs here.


#9

Yeah, those were good guides. Ok I will give it another try, I just configured them last night, so I didn’t have enough time to test or configure more.

Do you use a bezel for your CD-i? I tried to use one but the it didn’t show up… or maybe it was getting too late, and I was missing something lol


#10

No I don’t use bezels, but you can use it as overlay.


#11

that is well though :+1: thanks mate, I will try that


#12

@aorin1, How is it going? I have set up the philips CD-i since you posted this tutorial, I couple of games at that time and I quit until the logo screen. I said to myself, “I would try this philips cd-i system pretty soon”, well, that time was now lol… quite a long time lol.

I was trying some games and first thing I noticed is the mouse seems like jiggering and not responsive on the philips cd-i menu… where you have to press play to run the game after the light blue screen. Then I switch to MAME to check and the mouse works pretty well and the rest of the games too. Is there a configuration I would need to change on RA? However, MAME seems to be doing ok with the emulation.

Another issue I have found, is with the two games of Mad Dog McCree. After the light blue screen, I press play with the mouse and then I get a message saying: SORRY To play this disc your cd-i player must be equipped withg a CD-i Digital Video Cartridge

Honestly, I don’t what it is, since it is an in-game message. Or I am not sure if it is wearer MAME or RA.

Have you seen some of this issues? Regards


#13

Hey, the mouse thing seems to be connected with the cursor sensibility and I think you can lower it in MAME tab menu. Digital Video Cartridge games can’t be emulated in MAME AFAIK.


#14

Thanks, I will go back and adjust that. So I better use retroarch for the ma dog mccree games.

Thanks again for clarifying this


#15

Hey folks, Has anyone managed to get this working on a retro pie yet? I have tried so many configurations but none will work. Also how do you get chd files? I have bin and cue and also cdi files but can’t see chd. No asking for a link but a Google throws up nothing either do I have to convert them myself? I have managed to get the bin and cue working for messui under Windows. But the retro pie would be awesome!

Many thanks M


#16

I’m having issues with the Philips CD-i and getting it working on the GPD XD Plus (Android 7)

Following along with the advice here, I have converted a number of CD-i ROMS from .cue/ .bin to .chd. I have found the BIOS and placed it with my ROMS.

However, looking at the guide, it says to open up RetroArch and make changes to the following settings:

Enable Softlist (OFF) Media Type (cdrm) Boot from CLI (ON)

But, as I am using RetroRach on Android, I can not find these settings to change. Am I missing something?

There is someone on Youtube who has apparently got it working through RetroArch on their Galaxy S8+ (https://www.youtube.com/watch?v=SxsopNctAYg) and said they would write a guide, but as yet, has not posted one.

Does anyone have any advice regarding getting CD-i working through RetroArch on Android, or can you think of another way to get it working?


#17

Sounds like you need to 1st open anyother mame game with the core. Standard arcade game or something

Go into Quick Menu=>Options and set the ones required. Then save the game option file (otherwise this will be set for ALL games you load with mame core)

Go find the created .opt file RetroArch=>config=>MAME and rename it to the cdi game name listed in the .xml file for CDi in mama hash folder. (You should have that in your system folder for this all to work iirc)

Examples


#18

Fyi you would rename frogger.opt to “nameodcdigame”.opt


#19

Thank you for the advice and walk through. Really appreciate it. When I can, I’ll test this out and see if I can get it working. Cheers.


#20

Thank you again for your help and pictorial guide.

I followed your instructions and was able to get an .opt file to be generated for a game running in MAME. I edited the file name to the same as the CD-I game I want to use, and made the changes to the file as shown above (I changed "media_type = “cdrm” and also changed “softlists_enabled” to “disabled” and “Boot from CLI” to “enabled” (as detailed at the top of this thread) ) but I still get RetroArch crashing when trying to launch the game.

I paced the BIOS in the same folder as my ROMs, but also put a copy in the “system” folder of RetroArch as that’s where I have my other BIOS files that RetroArch uses. I will check the BIOS I’m using and maybe try another Core.

Any further advice would be most helpful.