Run Philips CD-i games in Retroarch (mame_libretro) via RocketLauncher


#21

Do you have anyother consoles seyup with mame?

Theres some other steps needed…

Follow this guide and apply it to CD-i for file/bios names.

Boot to bios should be off and software lists enabled. The original guide is for windows using an external launcher…android is different


#22

Any news on launching directly from RetroArch?


#23

Should be exactly the same as neogeo cd…just changing up the bios names and such


#24

This is my setup:

  • cdi220b.rom CRC: 279683CA
  • cdi200.rom CRC: 40C4E6B9
  • cdi220.rom CRC: 584C0AF8

MAME settings:

  • mame_alternate_renderer = “disabled”
  • mame_altres = “640x480”
  • mame_auto_save = “disabled”
  • mame_boot_from_cli = “disabled”
  • mame_boot_to_bios = “disabled”
  • mame_boot_to_osd = “disabled”
  • mame_buttons_profiles = “enabled”
  • mame_cheats_enable = “disabled”
  • mame_media_type = “rom”
  • mame_mouse_enable = “disabled”
  • mame_read_config = “disabled”
  • mame_saves = “game”
  • mame_softlists_auto_media = “enabled”
  • mame_softlists_enable = “enabled”
  • mame_throttle = “disabled”
  • mame_write_config = “disabled”

Without success. RetroArch just closes after launching the dummy.zip


#25

Try changing the media type to CD-ROM

What format are the cd-I games anyway? Could be worth a chd conversion but I have no clue.

I do know a guy that has this working on many games so it is def possible


#26

Changeing mame_media_type = “rom” to mame_media_type = “cdrm” did not help.

Games are in chd format.


#27

In another thread @zachmorris helps me to load and run properly CD-i games in Retroarch, take a look:

Has anyone managed to run CHD Philips CD-i game under windows?


#28

Ahhh so the games needed to be placed inside /cdimono1/ folder.


#29

So quick question, HOW do I get CDI games in this CHD format? I have been trying to run Mutant Rampage Bodyslam for ages, and I have it in both CDI and ISO formats, but never seen it in this CHD… how to get it?


#30

You can easily make the CHD with use of the chdman utility that comes bundled with the MAME Official emulator download. Have a quick search for chd conversion for all systems and you should find a recent ish thread with all the details for making chd images.


#33

I reported it in another thread but I see you managed to run the only CD-I game I’m unable to boot: The Apprentice.

How the hell did you manage to boot it ? Every other games work fine for me, but for some reason I just can’t start this one, I tried with MAME and MAME 2016, same result, can you confirm me you’re still able to boot this game with the latest MAME core update ?

I’ve been struggling for two hours, trying to check the dummy file names, the .xml listing, the .chd, I’ve got the exact same file as you, same configuration and same core options, it crashes Retroarch directly, I’m so lost and I hope you’re still around 'cause I can’t figure why this single game gives me so much trouble.

EDIT: Okay, after A LOT of trial and errors, I managed to get it to work. It works both on MAME 2016, and MAME cores, but apparently better to use MAME. Didn’t try MESS core 'cause I don’t use it at all.

Core options - All settings to NO Media Type = CDRM.

Start the game using the “.chd” file, no need for dummy file. I tried every other option, it doesn’t work except with these settings.

MAME 2016 - Game plays without problems, except minor visual glitches, but for some reason there’s no sound except, option is listed as N/A in menu and I can’t change the setting.

MAME - Game plays without problems, except minor visual glitches, and the sound is working for this version, I can change the sound effects to YES / NO in menu. Only problem I encountered, cinematic musics keeps playing sometimes when you enter the game, so let the cinematic plays to the end to avoid a music conflict between the one from the main level and the cinematic one.

It was such a pain in the ass to get this one working but I’m glad I managed to do it, the game looks pretty fun and definitely far above the usual CD-I standard. Would have been a pretty neat SNES game, too bad it never was ported on any other console.