Setting up Lakka for music playback

My apologies in advance if this is a topic that has already been brought up (my searches did not yield much).

I am setting up Lakka (2.3.1) on a pc (to be specific an HP Elitedesk 800 G1 USDT). The pc currently utilizes integrated graphics intel HD 4600 (no MXM card installed, yet) I am hoping to use the system as combination home-theatre and retro console setup. The only non-standard hardware is a 1tb SDD (Samsung) and a generic a/b/g/n wifi card.

I have not been able to get Lakka set up for music playback. My understanding is that audio/video playback is done through the FFmpeg core. When going through the installed cores, I notice that FFmpeg is not present. Has this been removed for a stability reason? I see that there is a package here: I am unfamiliar as to why it was not included in the installation. If it is safe to install, how would one go about doing so though SSH (I would be using SSH through Windows PowerShell)? Thanks for your insights!

Yes, ffmpeg core works, but that core is also usually baked into RetroArch. That is, just using ‘load content’ and navigating to a compatible file should load it.

Hi hunterk! Thanks for your response.

I did try doing a scan of the directory that is housing my .mp3 files. It is located in /roms/music. Prior to scanning the “music” directory, if I move to the music icon on the desktop “No music available” shows up.

I then go to the “Scan Directory” and direct it do /roms/music and select it. It immediately shows “Scanning of directory finished” in the bottom left. Unlike scanning roms, no files are displayed in the bottom left before indicating it has finished scanning the directory.

Once I go back to the music icon, it retains the “No music available” message.

Was I using the same ‘load content’ as you had suggested? On my layout it is next to the netplay icon

AFAIK, there is no way to scan for music. The music playlist is basically just a specialized ‘history’ playlist. So, once you load a music file, it should show up there for you to quick-load in the future. (and more importantly, not clutter up your regular history playlist with a bunch of music, pictures, etc.)

Okay. What would be the best way to get the content to load, if it is still showing that there are no media to load?

so ‘load content’ doesn’t show anything for you? in settings > file browser, can you try disabling “filter unknown extensions” if it’s currently enabled?

Thanks for your help hunter!

I can access file browser by going to Settings > Directory > File Browser > / .

I unfortunately am not seeing any options for “filter unknown extensions”. Could this be a UI difference?

do you have advanced options visible? settings > user interface > show advanced option ON

EDIT: whoops, I see that you’re on a different setting. The file browser options changed name/location recently and I’m not sure whether Lakka is on the new or old layout. You can also get to them by going to load content and then it’ll be the last option on that screen (with the two-gears icon).

Hey Hunterk!

I started a fresh install to start with default options. I have followed your advice and made advance options available (thanks for the description - Lakka must be on the old layout). While in settings I can now see Drivers, Video, Audio, Input, Latency, Core, Configuration, Saving, Logging, Frame Throttle, Recording, Onscreen Display, User Interface, AI Service, Power Management, Achievements, Wi-Fi, Network, Services, Playlists, User, and Directory. Unfortunately no file browser is showing up.

I did, however go to Settings > Directory and manually load an MP3 to play from the /roms/Music folder. It is the lone file that now shows up under music. It still remains to automatically load all music that is on the drive (about 60 test files organized in folders by album). Is there another way to access the “filter unknown extensions” option? I will SSH in again and browse the config file to see if there is anything in their as well.

In the old name/layout, it was the ‘settings’ option under ‘load content’ (it means ‘settings for “load content”’ not a link to the regular settings; yes, it’s confusing, which is why we changed it lol)

So, to reiterate: go to ‘load content’, scroll down to the ‘settings’ (should be the last one in the list, after ‘start directory’, ‘downloads’, etc.).

Like I said, though, I don’t think there’s any way to just add them all to the playlist. That’s done through scanning, and we don’t have any databases for music files.