Shaders look different on different displays

I connect a Surface Book 2 to a 1080p display and run a GameCube game with integer scaling on and using a combination of tvout+ntsc-2phase-composite+interlacing, and crt-lottes (480i mode off, shadow mask 1). On the laptop screen it looks good even without integer scaling on, but different, and at first I think it’s the resolution difference, but when I connect it to a 4K TV it looks the same as the 1080p one. It only looks different on the laptop display that’s 3000x2000 (less than 4K). Why is this?

Did you make sure everything had the same resolution when you tested? Laptop, retroarch, the display you connected to, this is extremely important.

I had to change the resolution under video in RetroArch to 4K manually when connected to the 4K TV, because it was set to 1080p for some reason, but it still looks 1080p even after changing it, as in the shader still has weird lines that I don’t see on the laptops display. When not connected to the TV, it’s 3000x2000, and looks that way (no distortions).

You’ll probably need to post some screenshots, showing what is actually going on…

The first image shows the laptop display. You see the weird lines swirling in the image, but they’re not visible while playing. However, the second image on the TV always shows these swirling lines. I don’t know how to fix it, they’re visible while playing on both my 1080p TV, and 4K (that’s a higher resolution than the laptop). Setting video to integer scale just moves the swirling lines to the corners. Whether integer scale, or not, they’re not noticeable on the laptop display (it looks great). I’m trying to make the picture look just as good as it does on the laptop display on either TV, since the laptop is screen is small and needs to be plugged in to run these shaders and LLE at a playable speed.

that’s an effect known as moire. Turn off the curvature effect and it should go away.


Thanks! Problem solved. Flat, integer scale looks fine on both displays. I’m still not sure why I can’t see the moire when playing on the laptop, but flat looks fine on the TV so I’ll just use that.