Shaders Not Saving/Loading on latest RA build

Hey all.

After updating to the 9-22-2019 nightly build, I can no longer get any shaders (cg, glsl) to save at any level (global, core, game) and automatically load on game start up with any of my cores (Mesen, Beetle PSX HW, Beetle Saturn, Genesis Plus GX).

I’ve been using my current setup with Retroarch for more than a year and have been able to change, modify and save my shaders at will with no problems until tonight. The only change I made was updating my Retroarch and cores using Stellar, which I tend to do at least once a week.

Now with this build, every time I try to save a shader as a core preset I first get an error message saying failed to save shader preset, then RA reverts to displaying no shader whatsoever.

Thankfully I have an older build of RA from last Monday that I went back to and everything works just fine.

Is anyone else having trouble with this? I am not sure if some setting I made a long time ago is now conflicting with a new RA update in the latest build.

Any ideas or help would be greatly appreciated.

well, the easiest way to check whether it’s a conflicting option is to move your retroarch.cfg somewhere else temporarily. If that fixes the problem, you can try bisecting the cfg (make a copy of the config, delete half of the options; if the problem goes away, you know your conflict is one of those options, if not, it’s in the other half; rinse/repeat until you isolate the setting)

1 Like

Great idea. Thanks, hunterk.

I removed the main retroarch.cfg file and booted up RA to create a fresh config, but the problem persists. I even reinstalled my old backup RA and that continues to work fine.

I’m really not sure where to go from here. I’ve put so many hours into getting this all set up and now I feel like I’m stuck with a build I won’t be able to update.

I would assume a nightly build isn’t the most stable, so I would try a stable release, or another nightly build to see if you have the same issues. From my experience, saving an override helps with shader presets not loading; sometimes the enabling of shaders for a core doesn’t save depending on how you exit the program after loading one.

This problem persist… (official repo installation on ubuntu mate) some news? RA right save “retroarch-core-options.cfg” on .config/retroarch/ but nothing about shader on this file… why?

unfortunately there is no other way to do it :sob:

Saving shaders should be fine. Just make sure in settings > directory that your video shaders directory exists and is user-writeable. Are you using the ‘save global/core/game/content dir preset’ option from the shaders menu?

If you verify all of that and it’s still not working, post a log of you trying and failing to save a preset and I’ll check it out.

Ciao @Nikoh77. RetroArch in the official ubuntu repos is a bit outdated

18.04 LTS - 1.4.1
18.10 - 1.7.3
19.04 - 1.7.3

Maybe you want to upgrade to the latest stable with the libretro PPA:

In one of the latest versions the behavior of how shaders are saved was changed. (i think in 1.7.8. IIRC)

official Retroarch repos (1.8.1) :wink:

Then you should be able to save your shader presets from the quick menu -> Shaders -> Save -> Global/Core/Content/Game Override

From the release notes:

This is why shaders are now only saved manually, giving more control over what content uses which shader.

1 Like

Ok Guys, thanks, problem solved… it was my fault… previously I saved the shaders with core override while now must be saved with shader menu… Sorry for my bad english :wink: and thanks.

Ok, now I have questions.

Are we still able to set a core override for shaders or does it have to be on a per game basis now?

You can save a global preset that’s used all the time, a core preset that’s just for that core, a game preset that’s just for that game or a content dir preset that’s for anything in the same directory as the currently loaded content.

1 Like

Alright that’s how I thought it worked before I had asked anything.