Shaders stopped working randomly?

I was using crt royale with several different emulators. Then after messing around with mendfen beetle settings, I went back to bsnes and the shaders won’t work even though it’s clearly applied in the shader menu. Won’t work with any other cores now either.

Anyone know what may have caused this?

Check to see if you’re trying to use the wrong shader format for the video renderer. Slang is Vulkan, GLSL and CG are both DirectX and OGL I think.


I’m still having this problem unfortunately. I seemed to have fixed it by switching from the cg version of crt-royale to the glsl version and it worked fine regardless of the core I was using(beetle, higan, genplusgx ect.) However, the problem came back today when I accidentally hit one of the hotkeys which cycled to a different shader. When I tried to change it back, the image wouldn’t display properly.

I figured it might help to switch to a newer version of retroarch, so Installed a 1.7.1. I then loaded up game in beetle, loaded crt-royale, adjusted the settings to my liking, and it worked the way it was supposed to. I then loaded sonic in genplus gx and the shader settings didn’t carry over, and when I tried tried to apply them, they didn’t display properly again, nor would they work right when I went back to beetle.

Oddly enough, when I take a screenshot in retroarch, this image comes out looking the way it’s supposed to. Anyone know what’s going on here?

So the image displays fine when retroarch is paused, but blurry (almost as if they’re vibrating) and weird in motion. I’m thinking the problem might be caused by the refresh rate? I tried following the calabration guide here(Perfect Audio Video Synchronization), but still no dice.