Simple Arcade Multifilter - app for MAME and FB Alpha ROM sets


#41

hi, thanks for your work. i just test and select only mechanical and unplayable filter and this software sort about 363 games non working. I test them in retroarch and effectively theses doesn’t work. thanks for your help now I can exclude them regards


#42

FIRST : thank you for holding up the work on your multifilter!!!

i think the filter (V1.1) miss some “not runnable” game like DOA2, DAYTONA2 and some other (mostly newer) games.


#43

What MAME version / DAT version are you using? I will need to look at those entries in the same DAT file you use.


#44

I used a 0.174 (MAME2016) rom-set and metadata…


#45

I added several DAT fields from newer DATs like 0.174 that were not detected. However, I am not sure that this will fix your issue because it should have already been detected.

Could you try again with the new SAM v1.11 build? https://github.com/markwkidd/ahk-retroarch-playlist-helpers/releases

Also, what is the source of your MAME 0.174 DAT? Are you using one you generated from within MAME or one that is published on the web?


#46

new release seems not change anything for me. I got the mame.dat and catver.ini from libretro back in days. maybe you can provide me the right one on your own ? :slight_smile:


#47

I think I have figured out the problem this time. There is now a v1.12 release which I think should do the trick: https://github.com/markwkidd/ahk-retroarch-playlist-helpers/releases/


#48

Hello markwkidd, the new version seem to be workling for me (it saves me arround 20gb storage space (y) ) now the sorted Set around 20 GB. I will give it a deeper try on weekend and report if anything intresting is going on …

thank you very much!!! :blush:


#49

Hi, i have tried a little bit and have noticed the following,

SAM:

-many not-working games are now filtered out correctly !!! great stuff!!! :smiley:

-few games that should (?) work are filtered out (can you check the taito G-Net and Sony ZN-1, ZN-2 libaries ? i noticed some games like Strider 2, Tetris Grand Master, shikigami, psyvariar, Xiistag are missing).

-at least one other game is missing too (probably more)… Dodonpachi Dai-Ou-Jou only showing a not working bootleg (!?)

-The “allways include Devices”-setting is useless when the “not runnable”-setting is activated. The Bios-Files are correctly included, but the devices are not.

Playlist Buddy:

-All “Devices” are hidden correctly but Bios Files are shown in the Playlist.


#50

I would like to try to narrow this issue about not copying games that are runnable. Could you help by providing me some more details on the romsets which are not being copied?

  • strider2 is marked as “Preliminary” in the MAME 0.174 DAT (aka Not Working) so it should not be copied. that seems correct as it is.
  • Which Tetris Grand Master romset is not being copied? There are a few titles with that phrase and I want to be sure of which one.
  • shikigam should be copied but shikgam2 and shikiga3 should not
  • psyvaria and psyvarrv should both be copied but psyvar2 should not
  • xiistag should be copied

#51

hello, i wish you a very nice new year-

i thought (or i was remembering) playing some strider2 and tetris grand master (tgmj.zip) with mame, but i can be wrong or something important with the copy protection is going on!? maybe its simply my fault…

the other games i miss (mostly Taito G-Net Hardware) are:

Psyvariar : Medium Unit

Psyvariar : Revision

Ray Crisis

Shikigami No Shiro / The Castle of Shikigami

Space Invaders Anniversary

Super Puzzle Bobble

XII-STAG

but other games with that (or similar to PSX Arcade) hardware are missing too! Thank you for great work again :slight_smile:


#52

I checked and this is not something I can address due to the various ways arcade DAT files are structured and the logic of applying the filters. I can’t remember for sure but I believe this is the reason why there is the text “Depending on MAME version this may filter out BIOS, Device, and Mechanical)” in the GUI.

For this case I suggest you run SAM a second time, selecting no categories but only coping the BIOS, Device, and Mechanical sets.

I’m looking at the other issues still.


#54

Thank you, this should be fixed in the next release once I see what is going on with these filters.


#55

My report so far: psyvaria and psyvarrv are going to be the test case.

They are copied properly with the “Running” romsets up through at least MAME 0.139 DAT format, however by at latest MAME 0.159 they are no longer being copied.


#56

I have published a new release which I think will fix this. Do you mind testing v1.13 when you have a chance? https://github.com/markwkidd/ahk-retroarch-playlist-helpers/releases

Also there is some more refinement about filtering BIOS, Device, and Mechanical in SAM with this release.

I’m still looking at the problem with the “runnable” filter.


#57

@shakalakka I thought I was not going to be able to find the problem this week, but think I did find it after all. SAM was over-zealously filtering romsets with nodump and baddump roms even if the romsets were marked as runnable.

I have just uploaded a v1.2 build which I hope will resolve these issues: https://github.com/markwkidd/ahk-retroarch-playlist-helpers/releases


#58

Hello, nice to see you working again on the sorter / lister.

Device are copied to the set now! Great!!!

Some games wich are not included are included now correctly (for example the SFIII Chd games or Tetris Grandmaster). But some games are still not included … like the Taito G-Net based Games (Psyvariar : Medium Unit, Psyvariar : Revision, Ray Crisis, Shikigami No Shiro / The Castle of Shikigami and so on)

Maybe i try the new PL Buddy too, later.


#59

Well dang about psyvaria! :japanese_ogre: :slight_smile: Thank you for all of your testing. It is very helpful to me and to other users.

I specifically tested with the psyvaria romset, which is titled “Psyvariar -Medium Unit- (V2.04J)” in your version. I used the MAME 0.174 Arcade DAT from the MAME 2016 libretro github repo.

With v1.2 of SAM yesterday, the psyvaria romset was correctly included when it copies runnable games.

I want to make sure I’m doing this the exact same way you are. Is that your situation?


#60

i am not sure about the files… maybe you can provide me with the github link to download the MAME2016 metadata files?

EDIT: The missing games seems to be CHD-Only games (without a additional ROM-file like most other CHD-Games have) maybe this can be the troublemaker?


#61

I have not looked at the CHD handling code in a while – I mostly use MAME 2003-Plus so I rely on other people to remind me about the other versions of MAME :blush:

For bugs I need to have a romset name to test with. What is the name of a working/runnable romset in MAME 0.174 that is CHD-only?

PS You asked about the DAT. I am pretty sure that I am using the same one as you but the one I’m using came from the MAME 2016 github repository here: https://github.com/libretro/mame2016-libretro/tree/master/metadata