[Solved] 1.7.8 - Slang shaders no longer working on some cores


I have a custom made Slang shader that I use when playing games with RetroArch. However, after updating from 1.7.7 to 1.7.8, it seems that when using certain cores, I cannot use Slang shaders anymore, only GLSL and CG ones.

The problematic cores are 4DO, Beetle Cygne and Beetle PSX. In any other core, Slang shaders work fine and I can’t figure out why they stopped working in these three cores in particular. They worked fine in version 1.7.7 of RetroArch.

I’m using the GLcore video driver. Switching to Vulkan or D3D12 fixes the issue, but I’d rather use GLCore due to both my shader and OBS Studio not working well with other video drivers.

I figured it out. The Threaded Video setting caused shaders to not work for some reason. I had the setting automatically enabled for these cores. I disabled Threaded Video and now the shaders work again.


Thanks for explaining!

1 Like

This is fixed for the next build/nightlies. It’s actually caused by an ancient bug that surfaced about 2 months ago. Took till today because seemingly nobody was using threaded video with nightlies. Relevant GitHub issue.

1 Like