[SOLVED] PPSSPP No text in some games

Just wanted to let people know of an issue I encountered and how to fix it.

I was trying to run Dissidia in PPSSPP and it was crashing right after I selected “New Game”. Running in Verbose mode actually didn’t even let me run the game at all. I finally figured out that it was just that I needed to disable “Fast Memory (Speedhack)”.

After I did that I was able to load the game but then I ran in to another odd issue. I saw prompts with no text in them. Everything was blank. I couldn’t tell what options were what. When I attempted to run in Verbose earlier for the other issue I remembered seeing another error that mentioned something about fonts. So I ran in Verbose again and noticed that it was trying to load a font file in the System directory that wasn’t there.

It turns out that there are actually several font files that some games need in order to display text on the screen.

So here is how you fix that issue.

  • Go in to the file system of your device running Lakka and go in the the System folder.
  • In the System folder you should already have a folder named PPSSPP where your BIOS is stored.
  • In the PPSSPP folder, create another folder called “flash0”
  • In the “flash0” folder, create a folder named “font”
  • Now go to https://github.com/libretro-mirrors/libretro-ppsspp/tree/master/flash0/font
  • Download all the font files form there and place them in to the “font” folder you created.

Path should look similar to this when you are done. /storage/system/PPSSPP/flash0/font/jpn0.pgf

There you go! Now you should have all the fonts.

I see that these files obviously exist in the libretro-ppsspp build because that’s where I got them. Not sure if this is something that can just be adjusted to have them automatically come with each build of Lakka in the future…