SOLVED - Problem cloning LAKKA to larger SSD

Hello All !

So I was running Lakka on a Lenovo M900 tiny PC with a 256GB SSD and running out of room for everything.

My “Windows Brain” said ‘Oh just clone it to a larger SSD with Acronis True Image, it’ll be fine’ …

45 minutes later (and letting Acronis resize the storage partition) I have a hot mess …

When trying to boot from newly created 1TB clone I get the following error on screen.

------- here is the message ------

*** Error in mount_flash: mount_common: Could not mount UUID=A3F6-2BE4 ***
### Starting debugging shell for boot step: mount_flash... type  exit  to quit ### 
# _

Now I believe it would be the bootloader complaining because both the drive is different (UUID) and the storage partition is now 3 times larger. But I have not the Linux knowledge to do anything about it.

I would really like to avoid having to reinstall and configure everything if possible.

Humbly asking for help…


Update 2hrs later:

With the 1 TB SSD still in the machine I connected the original SSD via a USB dock and booted to Clonzilla Live. I performed a device to device clone on auto settings and it worked with the exception that it is identical in partition size. Now trying to see if I can expand the storage partition without using gparted from a bootable usb.

Update 2.5hrs later :

Booted to usb, resized partition with Gparted. All good.

Lessons learned when upgrading size of HDD/SSD :

  • Do not clone outside of the machine you want to use it in and then try to edit UUID afterwards.
  • Put destination drive in the machine and source drive in USB dock.
  • Clonzilla Live and Gparted Live are your 2 best friends.
  • Do not bother the nice people on the forum when you can fix it yourself with experimentation (my bad, sorry)
  • Leave your experience on the forum so other can either point and laugh, or learn something.

Is this a Linux thing? Because in Windows i do both the cloning and resizing with minitool partition wizard. I even cloned a softmodded Wii hard disk with it (from IDE to SATA) and it worked. I also don’t have to follow rules like having the destination disk in the machine, etc.

No, it’s a Me thing :slight_smile: I prefer to have the destination drive in the machine it is going to live in… Writes seem a bit faster. :slight_smile: