[SOLVED] Super SNES Joypads don't work after X seconds

Hi everybody :grin:

Solution -> [SOLVED] Super SNES Joypads don't work after X seconds


SNES Joypads doesn’t work after X seconds of connecting them to a Cubox-i board with Lakka 2.1


I recently bought this Chinese controls QUMOX on Amazon …

To connect them to a CuBox-i board …

I plug one of two joypads and Lakka version 2.1 recognized the joypad as SNES-style usb with the next config:

Lakka:~/joypads/udev # vi usb\ gamepad\ \ \ \ \ \ \ \ \ \ \ .cfg
input_driver = "udev"
input_device = "usb gamepad           "
input_vendor_id = "2064"
input_product_id = "58625"
input_b_btn = "2"
input_y_btn = "3"
input_select_btn = "8"
input_start_btn = "9"
input_up_axis = "-1"
input_down_axis = "+1"
input_left_axis = "-0"
input_right_axis = "+0"
input_a_btn = "1"
input_x_btn = "0"
input_l_btn = "4"
input_r_btn = "6"

The Vendor ID (0810) and Product ID (e501) are correct in decimal 2064 and 58625 respectly

Lakka:~/joypads/udev # lsusb
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 004: ID 0810:e501 Personal Communication Systems, Inc.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

But this is the problem:

After X seconds (between 1 and ~120) the joypad don’t work. :frowning_face:

I tried to see any log like this Lakka supports page says. When I start Lakka with log and verbose and I connect the joy pad and wait when joypad don’t work, these are the last lines of log

Lakka:~ # systemctl stop retroarch.service ; LIBGL_DEBUG=verbose retroarch --menu --verbose >> log.txt 2>&1
[INFO] [udev]: Plugged pad: usb gamepad            (2064:58625) on port #0.
[INFO] [udev]: Pad #0 (/dev/input/event0) supports 0 force feedback effects.
[INFO] [Autoconf]: 191 profiles found.
[INFO] [Autoconf]: selected configuration: /tmp/joypads/udev/usb gamepad           .cfg

And in dmesg output this last lines

[ 2014.992049] usb 1-1: new low-speed USB device number 12 using ci_hdrc
[ 2015.122748] input: usb gamepad            as /devices/soc0/soc/2100000.aips-bus/2184000.usb/ci_hdrc.0/usb1/1-1/1-1:1.0/0003:0810:E501.0013/input/input21
[ 2015.124173] hid-generic 0003:0810:E501.0013: input,hidraw0: USB HID v1.10 Joystick [usb gamepad           ] on usb-ci_hdrc.0-1/input0

I’m stucked. I don’t know what else to do. Any suggest? I read this post [SOLVED] Generic chinese controllers on Lakka? Chinaware Best practice but I think that I have another problem. My chinesse joypads works but only X seconds :frowning:

Thanks so much :kissing_heart:

UPDATE: The problem is that this Chinesse Joypad needs a powered USB hub to work propertly.

Those log snippets look okay, AFAICT. I don’t know what could cause such a thing to happen, other than maybe overly-aggressive power-savings settings turning off USB after a period, but I would expect more reports before this one if that were the case.

1 Like

Hi, thanks so much for your answer @hunterk

That option is discarded because in the 2 USB ports that Cubox-i has, in one of them I have plugged the joypad controller and in the other USB port the keyboard. And only the joypad controller stops working after X seconds. The keyboard works.

I need to see more logs because dmesg is OK, Lakka with log and verbose is OK. Any more ideas to debug this possible bug?

Thanks @everybody

Does this happen with just one plugged in?

Can you try to use them through a powered USB hub?

Does this happen with them plugged into another system/platform?

1 Like

Hi @markwkidd , thanks for your reply. I’ll answer all questions:

Does this happen with just one plugged in? It happens with both joypads controllers in any configuration (1 pluged, both pluged, 1 pluged and keyboard, 1 pluged and mouse)

Can you try to use them through a powered USB hub? I don’t think that it was a power problem because, optic mouse and keyboard with leds works.

Does this happen with them plugged into another system/platform? The joypad controller works on Windows 10

Problem continue :disappointed_relieved: both joypads controllers freeze after X seconds to connect in a Cubox-i board with Lakka 2.1.

Thanks 4 all

Not all devices draw the same amount of power from USB. I think a powered hub test is worthwhile if possible.

1 Like

since this is some sort of “mini” computer, you should follow markwkidds suggestion for now and test. who knows what kind of power supply you are running this system with too or if the ports are able to support whatever the joypads+usb devices thats plugged in, or if this “chinese” **** does follow the usb specifications etc!

1 Like

Ok @markwkidd and @wertz. I’ll try this afternoon with a powered USB hub :wink:

See you

UPDATED: The problem persists :slightly_frowning_face: :slightly_frowning_face: :slightly_frowning_face:

I tried this Powered USB Hub and after X seconds the game controllers don’t work.

Which system logs of lakka can I see to get more info?

Thanks @all

I’ll try to pull this way. There is a utility to check that the controls are responding, called jstest. Thank you @vudiq on FreeNode #lakka IRC


I record 2 videos with the problem. The first I connect the SNES joypad controller to Cubox-i and then you will see how the joypad didn’t work after 15 seconds.

And the next video I stop retroarch and user jstest

systemctl stop retroarch
jstest /dev/input/js0

:persevere: Any solution?

Thanks in advance

the question before your post, is if the joystick is working at all with other available system/app for this system?

1 Like

@albertoiNET I would try a different controller. It seems highly likely that is where the fault lies here.

1 Like

Hi everybody

Both are working on Windows 10. So both working in diferent

I bought 2x Super SNES Joypads and both didn’t work. It’s possible that the problem was the SuperNess Joypads? With Keyboard I can play to games, but no with this 2 controllers.

:sob::sob: It seems that is a bug?

May I can post a bug on github?

Thanks 4 All

Yes it is entirely possible that 2 cheap chinese controllers don’t work right. You get what you pay for…

1 Like

SOLVED!! :smile:

My apologies @markwkidd . I probed with another Powered USB Hub and joypads are working. You’re right.

Problem Solved. Both Chinese joypads consum a lot of energy and don’t work after X seconds. But with a powered USB hub both are working. Thanks 4 all


Believe it or not, I bought extra 4 pieces of 10 meters long USB cables to play in the living room on the TV with various Chinese controllers. Pictures here: https://forum.recalbox.com/topic/3502/solved-how-to-configure-several-same-name-controllers-chinaware-in-recalbox

I use Lakka on a Dell Optiplex 790 without USB Hub and it works great.