SSH password

I’m running Lakka-RPi4.arm-2.9-devel-20190723035023-70412e1 on my Pi 4 and I’m trying to access it via PuTTY from a Windows 10 machine. I’m using the correct IP address for the Pi but the default SSH username and password (root/root) isn’t working for me. It just says access denied. Any help appreciated!


Did you follow these instructions?

1 Like

Yes, I followed the SSH method listed here. SSH is enabled on Lakka. Still no luck.

Have you tried “lakka” as both user and password?

Okay…lakka as both user and password didn’t work so I tried user root and password lakka and it worked! Thanks for your help everyone. I appreciate it!


For the record (and anyone finding this topic on Google), the new LE9.2 based builds have root / lakka as ssh credentials. This will most likely be changed to keep consistency with current versions of Lakka


What’s the password for the lakka partition? (The one that contains config.txt) I tried root, lakka and root and raspberry. No dice.

What do you mean by password for the partition ? It’s a classic FAT32 partition there’s nothing protected about it

However it’s mounted read only so you need a PC to edit it

That’s what I meant, more or less. I wanted to know if there was any way to edit config.txt over SSH. I can that with Raspbian. It makes it easier to switch between different modelines if you’re using a CRT. Image that I’m playing a Neo Geo game at x224 vertical res, and then I want to play an N64 game at x240 vertical res. If I have to remove the SD card and go to my PC and edit the modeline, it’s kind of a pita. Looking for a way to SSH into the box from a PC, edit the modeline, and then reboot it. Still a pita, but at least I don’t have to shutdown, remove the SD, stick it in a card reader, etc, etc.

Is this impossible, or is it just a permission issue or something?


This is what I believe you’re looking for.

The FAT32 partition is mounted read-only as /flash on the Lakka box.

You may be able to remount it read-write by using mount -o rw,remount /flash but I have never done it so I can’t tell if it works or not. Otherwise you indeed need a PC to edit the files or unpack, edit and repack the initramfs to mount /flash read-write on boot

What natinusala indicates is correct.

It is on the LibreELEC wiki:

I have always been able to get in with root/root

how do you update the raspberry pi firmware in the ssh (with lakka)

What are you calling “firmware”?

The most probable update is: you don’t. Lakka ships with a read-only “firmware” that gets updated when you update Lakka

I’ve been trying to get ssh access working the last 2 days, and just can’t get it to work. It will take root/root in Putty, but then it just hangs. Same thing on Ubuntu on via Hyper-v.

This is what my cmdline.txt reads: boot=LABEL=LAKKA disk=LABEL=LAKKA_DISK BOOT_IMAGE=/kernel.img quiet vt.global_cursor_default=0 loglevel=2 console=tty3 ssh

I’ve tried it with retroarch=0, but it didn’t make a difference. Any help at all would be greatly appreciated.

Yes, you can update the raspberry pi firmware through Lakka over SSH, I’ve done it twice so far.

There’s a good guide here on the raspberry pi forum:

The post is from a Pi engineer, which is good, but it’s disappointing that this lives just in their forum and not on a proper page. Personally, I downloaded the posted file to my PC, copied it to my Pi over SAMBA, and then executed the logic described in his post. Note that the file has been updated since his post, so the filename posted at their Google Drive (!?) has changed, so you will have to slightly modify the script.

It is definitely a good idea to patch your Pi4 firmware - the USB stack on the stock firmware has real problems, and there are heat (which means power waste) problems too.